Port not in Correct Vlan

Unanswered Question

I setup a new Cisco Switch and when I setup a port on the switch to be in the correct VLAN it dosen't work. My VLANs show up on the switch, but this port will not take it. Here is the port config:

interface FastEthernet0/19

description Admin_Second_Floor_#

switchport access vlan 60

switchport trunk encapsulation dot1q

switchport trunk native vlan 60

switchport mode trunk

switchport voice vlan 20

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

end

And here is the output from the sh vlan command:

60 active Fa0/2, Fa0/4, Fa0/5, Fa0/6

Fa0/8, Fa0/10, Fa0/13, Fa0/18 Fa0/23, Fa0/31, Fa0/32, Fa0/33

Fa0/34, Fa0/35, Fa0/36, Fa0/37

Fa0/38, Fa0/40, Fa0/41, Fa0/42

Fa0/43, Fa0/44, Fa0/45

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cpubob Thu, 01/03/2008 - 11:27

its because you made the port a trunk with the "switchport mode trunk " command. If you want it to be an access port, set it back with the command "switchport mode access".

HTH :-)

Richard Burts Thu, 01/03/2008 - 11:30

Mark

Perhaps I am missing something. When you configure the port as a trunk:

switchport mode trunk

what did you expect the switch to do? As a trunk the port is not a member of any specific VLAN but carries traffic from all VLANs.

HTH

Rick

I copied the config from a running switch. I just took over this network and have only just gone through the ICND 1 and 2 classes so I am just really learning it. I find it interesting that only this port is having the problems. The users on other ports of the switches don't have this issue. I removed the line and set it back to an access port and it shows up under the correct vlan now, but the device connected to it still dosen't work.

stephenshaw Fri, 01/04/2008 - 05:27

Hi,

this is a standard configuration for IP phones. I would suggest trying to add this statement and see if the output changes:

"switchport trunk allowed vlan 20,60"

With the exception of this command, your config is done exactly in the same manner as we do ours. All of our ports come up in the correct VLAN.

Good luck,

Steve

I tried that and I was able to ping the device. I removed it and I was still able to ping the device. I changed the VLAN to a different one and now I can't ping the device. I added that line back in and it didn't work. This is the exact config that I have on all my other switches and they work just fine. It is just this one that is acting up. I find that if I change the VLAN it isn't showing up that it is in the correct VLAN when I do a sh vlan.

chschroe Sat, 01/05/2008 - 01:12

What all is out the interface? If its just the phone, and not a user and the phone, you won't see anyone on 60.

If you really want to simplify it down, all you need is:

switchport mode access

switchport access vlan 60

switchport voice vlan 20

plus your QoS configuration. That's it!

NS

johgill Sat, 01/05/2008 - 08:35

Note: "sh int trunk" shows you what VLANs will be forwarding on that link. This sounds like the interface configuration may not be the issue here though.

Actions

This Discussion