problem to change management ip on catalyst 500

Unanswered Question
Jan 4th, 2008


I have a problem with a catalyst 500.

The network background is: a little office network with my catalyst, a router 2811,and a access point, all of them are running, and working perfectly. I want to move the management ip in a management lan(the router and the ap, working with the management lan).

I tried to change the management ip at my catalyst 500, the strange fact is: If I want to change the ip in the same subnet(ex: -> the device work great and it let me change the ip. But, when I tried to change the ip in the another subnet(ex: ->, the device doesn't let me do this.

I know my problem seem easy(I thought), but still I am not able to resolve it.

I was looking for in the documentation of the catalyst, but I could not find nothing good.

I proceed in this way:

I connect my laptop in the fas 1 and I configured my computer ip with, and I tried to change the ip on the switch, but doesn't work. Maybe I have to press the setup button?!If yes, pls can you tell me exactly when?

Some of you had got the same experience? This is the first time that I use this series of switch.

Thank you in advance, greetings Antonello Moneta

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
antonello.moneta Fri, 01/04/2008 - 06:52

Thank you, but I already know this link. I read this document, and I follow it, but I could not resolve my problem.

Thank you anyway. greetings Antonello

aborole Fri, 01/04/2008 - 07:04

Do you get error during express setup after following all instructions and changing IP address of device to belong to another subnet ? Just want to understand what you mean by the device does not let you assign adderss from another subnet.

antonello.moneta Fri, 01/04/2008 - 07:28

Well, the only error is the browser try to connect to the new address, and fails.

Anyway, I didn't follow exactly the instruction on the documentation you send me, because the docs are about the first installation, and I already make the fist setup of the device one year ago.

Thanks you a lot, I know my english is very bad :), I hope you can understand the situation.

Greetings Antonello.

aborole Fri, 01/04/2008 - 07:59

It seems like the address change was done correctly and browser cannot reach that address just because your PC is not on same subnet. If you are not using express setup, why do you want to connect your laptop directly to the CE500 ? Can you not manage it using that device remotely like other devices ? Once your laptop is on the network (and not connected to one single device) you should be able to reach all devices including the CE500 whose address you changed.

antonello.moneta Fri, 01/04/2008 - 08:12

ok, I just resolve the problem. I think the main action you have to do are: pressing setup button before to start a browser session and put as gataway of your laptop network config the actual switch ip address(so that the switch can redirect your browser). Anyway, here I write what I did, just if someone will got the same problem:

1. I put fas 1 on vlan 1 -default-

2. I configured my laptop ip:, netmask:, ed gateway: actual switch ip address).

3. I press setup button(led blink green), on the switch, connect the my laptop to fas 1(also, led blink green).

4. Put in the browser, the actual address of switch, in my case Anyway the address is not important because a you will note browser redirects you at switch management web-pages at ip address

5. Now you can change the ip address and gateway of you catalyst 500, press setup button (led must stop blinking and switch off). Now you can access to the switch at new address (and eventually vlan) that you setup before.

Well, I hope this post can help someone. And I hope cisco will put a better docs in the future.

greetings Antonello.


This Discussion