Please help understand this IP-MPLS-ATM config

Unanswered Question
Jan 4th, 2008

Can you check if I understand the following config correctly?

There are two devices Router-1 and Router-2. Vlan100 is the interesting traffic. Router-1 handles IP routing for the vlan with a subinterface configured. Router-2 has the ATM WAN connection, and also has a layer 2 interface configured for the vlan to transport MPLS over the ATM subinterface.

Is my understanding correct? My questions are:

a. Is the whole config intended to establish IP OSPF between Router-1 and a device such as a MPLS PE? Router-2 is just a device providing ATM WAN connectivity?

b. Is it appropriate to configure layer 2 vlan interface on Router-2 by using "mpls l2transport route"? How does it link the vlan to the ATM subinterface?

c. Is the IP and OSPF config of the ATM subinterface intended to set up IP connectivity with a ATM device on the other end (not the PE)?

d. If I want to collapes Router-1 into Router-2, can I jut make Router-2's layer 2 vlan interface as layer 3 by adding IP address to it and also "ip ospf network point-to-point"? Would that work with the statement of "mpls l2transport"?

d. Is there a reading to understand the relevant configs?

Thanks a lot

Router-1#

interface GigabitEthernet0/0

no ip address

duplex full

speed 1000

!

interface GigabitEthernet0/0.100

encapsulation dot1Q 100

ip address 10.1.1.1 255.255.255.252

ip ospf network point-to-point

Router-2#

interface GigabitEthernet1/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100

switchport mode trunk

no ip address

interface Vlan100

no ip address

mpls l2transport route 10.10.10.250 100

!

interface ATM2/0/0

no ip address

atm scrambling cell-payload

atm framing cbitplcp

!

interface ATM2/0/0.100 point-to-point

ip address 10.2.2.1 255.255.255.252

tag-switching ip

pvc 2/33

vbr-nrt xxxxx xxxx xxx

encapsulation aal5snap

!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
marikakis Fri, 01/04/2008 - 12:05

Hello,

a) The configuration of Router-1 that you supplied suggests only that Router-1 is supposed to become OSPF neighbor with a single other router that also resides on VLAN 100 and has an IP address 10.1.1.2 on the same /30 subnet as Router-1. None of the configuration that you show us from Router-2 suggests a relationship between them, besides their being on the same VLAN. I do not see anything in the config of Router-1 that you show us saying anything about MPLS. Router-2 has some MPLS configuration.

b) The VLAN interface is not literally connected to the ATM sub-if. These are 2 different MPLS configs. The config of the VLAN sets up an AToM VC over the MPLS core towards some peer residing at another point in the network. In that sense, maybe you can say that there is a "connection" between the gigabitethernet and the MPLS backbone.

c) ATM PVC on Router-2 means there is another router over the ATM cloud probably with an ATM PVC endpoint(could be Frame-Relay endpoint, ATM/FR VCs). IP and OSPF config setup IP connectivity between those 2 routers. The peer router at the other end of the ATM VC is a P router with a frame-mode MPLS enabled subinterface. I cannot know if this router is also a PE, I only see an implied connection to the MPLS core, but cannot see any customer connections (no supplied config for the peer at the other endpoint of ATM VC).

d) AToM and simple IP connectivity accomplish different goals. You have MPLS core and you setup a layer-2 style VC mechanism over MPLS. Why would you want to move to a traditional layer-3 mechanism and also run OSPF with the peer? Those 2 will not work together (I mean both configs on the same logical interface will not work).

e) You might want to have a look at what AToM accomplishes: http://www.cisco.com/en/US/products/ps6646/products_ios_protocol_option_home.html

and some AToM configuration:

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00804a0d1b.html#wp1035449

Kind Regards,

M.

Actions

This Discussion