7921G Not connecting

Answered Question
Jan 4th, 2008

I have a 7921G W phone that I cannot get connected to a WAP. I have factory reset the phone, and configured it only for the SSID and open authentication nothing else. I have setup the WAP with only an SSID in Guest mode and put the world mode command under the Dot11 interface. I cannot get the phone to connect to the AP. I also cannot see the AP from the phone's Site Survey utility.

I am seeing probe requests being generated by the phone using AirMagnet but I am not seeing any probe responses.

Thanx for the help.

I have this problem too.
0 votes
Correct Answer by migilles about 6 years 3 months ago

Why are you ordering -W model 7921G if you are in the US? Should order -A model.

What model is your AP?

What channel is your AP on? Need to ensure it is using a 1-11 channel.

7920 doesn't use world mode. It has it's own regulatory domain (channels and tx powers to use) info.

So world mode is just info for the client to use if it can.

So you can enable world mode and both 7920 and 7921 can both work as long as you have a country code and channel that the 7921G supports. Quite a few countries supported are in the 7921G Design Guide.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
migilles Sat, 01/05/2008 - 21:08

Ensure the SSID length is accurate in the probe request from packet capture. Maybe you have a space at the end of the SSID in the network profile config.

If there is no probe response, then the 7921G phone will not attempt to authenticate with the access point.

World mode config is only required if you have a -W model 7921G phone, but only recommended for -A, -E or -P models.

srosenthal Sun, 01/06/2008 - 16:20

I do not have an SSID configured in the phone. I was under the impression that the Site Survey function would at least show me wireless networks found. It certainly did not work when I did enter in the SSID for working network.

When trying to connect to an actual working VoIP network over wireless I could not get the phone to associate to the WAP. I have 3 working 7920 phones.

This 7921G is a W model phone.

migilles Sun, 01/06/2008 - 19:33

Can not have a network profile configured with a 0 length SSID.

The site survey in 1.0.X code will only scan for configured networks (SSIDs). So will not show all APs in range with just any SSID like the Airmagnet application.

Ok if you have a -W model, then you must configure world mode on the AP. Is enabled by default on the Cisco WLAN controller, but not on the autonomous / standalone AP.

Which country code are you trying to use?

The 7920 does not support 802.11d / world mode and will only use local regulatory domain configuration depending on the model (Americas, EMEA, Japan, APAC, and Australia/New Zealand).

http://www.cisco.com/en/US/products/hw/phones/ps379/products_data_sheet09186a00801739bb.html

srosenthal Mon, 01/07/2008 - 04:29

I will add the SSID into the phone and see what happens.

I did configure the world mode on the AP and used the country code US.

So you are saying that the 7920 and the 7921W will not work on the same AP if the AP is set for world mode?

Thanx

srosenthal Mon, 01/07/2008 - 12:07

I placed the SSID in the phone for the AP I am using and still no luck. Here is the config for the AP.

dot11 ssid SiteSurvey

guest-mode

!

!

!

username Cisco password xxx

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid SiteSurvey

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

channel 2412

station-role root

world-mode dot11d country US both

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

The phone shows a red slash thru the antenna icon and nothing comes up on the Site Survey utility.

migilles Mon, 01/07/2008 - 14:08

I see you have capital letters in your SSID.

Ensure the case matches in the 7921 as well.

If you sniff the probe requests from the 7921 should see length 10.

But also see you haven't configured authentication or optional encryption.

You need the following if 7921G is set to open.

dot11 ssid SiteSurvey

guest-mode

authentication open

Correct Answer
migilles Mon, 01/07/2008 - 13:52

Why are you ordering -W model 7921G if you are in the US? Should order -A model.

What model is your AP?

What channel is your AP on? Need to ensure it is using a 1-11 channel.

7920 doesn't use world mode. It has it's own regulatory domain (channels and tx powers to use) info.

So world mode is just info for the client to use if it can.

So you can enable world mode and both 7920 and 7921 can both work as long as you have a country code and channel that the 7921G supports. Quite a few countries supported are in the 7921G Design Guide.

srosenthal Mon, 01/07/2008 - 14:58

The config that I have above was just on a 1231G that I setup in my lab. I forgot to add the authentication open command.

My customer got the phone from his sales rep, not sure why they got the -W phone. They have four 1231G AP's installed at their location and they are all within channel 1 thru 11.

I did verify that the SSID in the phone is spelled correctly with uppercase where appropriate knowing SSID is case sensitive.

I will setup lab ap with "authentication open" and see what happens. Might not be until Wednesday though. I will keep you posted.

Seth

srosenthal Wed, 01/09/2008 - 08:29

Thank you for the help. The world mode command did the trick in the live network.

Actions

Login or Register to take actions

This Discussion

Posted January 4, 2008 at 12:45 PM
Stats:
Replies:9 Avg. Rating:5
Views:534 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard