RIP: Summary networks don't propogate.

Unanswered Question
Jan 4th, 2008
User Badges:

Hi all,


I have two routers connected over a third router that is emulating a frame-relay cloud.


I have set up lookback interfaces on the routers and am trying to use RIP to propogate these routes - summarised.


ROUTER A has the following lookback interfaces:


interface Loopback0

ip address 192.168.1.1 255.255.255.0

!

interface Loopback1

ip address 192.168.16.1 255.255.255.0

!

interface Loopback2

ip address 192.168.32.1 255.255.255.0



ROUTER B has the following lookback interfaces:


interface Loopback0

ip address 172.16.18.1 255.255.240.0

!

interface Loopback1

ip address 172.16.76.1 255.255.240.0

!

interface Loopback2

ip address 172.16.192.1 255.255.255.0


And this is the RIP configuration:


ROUTER_A

router rip

version 2

network 10.0.0.0

network 192.0.0.0

neighbor 10.10.10.6



ROUTER_B

router rip

version 2

network 10.0.0.0

network 172.0.0.0

neighbor 10.10.10.5


However, the routers are not exchanging the routes to the loopback addresses.


More info:


With the debug ip rip turned on, I can see that neither of the routers is even sending the loopback summary address of 192.0.0.0 or 172.0.0.0.


What am I missing here? It does work if I change the statements in RIP to reflect classful networks, i.e. e.g. 192.168.1.0.




Thanks in advance.


Kind regards.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Fri, 01/04/2008 - 20:03
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You have to match the networks in order to enable RIP on the interface and the only way to enable RIP on those interfaces is to include the network command to match the class boundary.


For class A networks, all you need is the first octect (10.0.0.0), for Class B networks, you need two octects (172.16.0.0) and for Class C networks, you need three octects (192.168.x.0).


If you don't want to type all the Class C networks, just enable RIP on the interface facing the other RIP speaking devices and redistribute the loopbacks.


router rip

redistributed connected metric 1

royalblues Fri, 01/04/2008 - 21:57
User Badges:
  • Green, 3000 points or more

I addition to Edison's post if you need to run RIP on all interfaces, you can use the following network command


router rip

network 0.0.0.0



HTH

Narayan

network_enginee... Sat, 01/05/2008 - 02:52
User Badges:

Hi all,


Thanks for the response. That is exactly my question, i.e. when I use the classful network, e.g. 192.168.x.0, then it works, however, when I summarise it to 192.0.0.0, then it does not. RIP v2 supporting classless routing, *should it not have been able to* propogate summarised networks? Or what am I missing here?


Kind regards.

chschroe Sat, 01/05/2008 - 03:18
User Badges:

You need to apply a summary address and mask.


RIP is behaving correctly. 192.168.x.0 IS the correct bit boundary to summarize on, and 192.0.0.0 isn't. All it knows how to do by itself is boundary summarization.


You can always add an ip summary address rip to your advertising interface, and whatever major boundary you'd like, and it will do it. But it still has to fall on a major boundary that the contributors can be summarized together into (it isn't arbitrary, like an acl for example).


NS




Edison Ortiz Sat, 01/05/2008 - 05:48
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You don't summarize when enabling RIP on an interface (that's what the network command does).


If you want this router to advertise 192.0.0.0/8 instead of every single loopback address, you need to use ip summary-address rip 192.0.0.0 255.0.0.0 on the interface facing the RIP routers. However, you must first enable RIP on those interfaces by entering the network command (with classful boundary) or using the redistribute command as explained before.



Edison Ortiz Sat, 01/05/2008 - 09:16
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Paolo,


You are indeed correct. I should've labbed it before posting:



R1(config-if)#ip summary-address rip 192.0.0.0 255.0.0.0

Summary mask must be greater or equal to major net



Thanks

Richard Burts Sat, 01/05/2008 - 09:33
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Ben


I believe that there is a slightly different way to look at this and to understand the issue. I go back to one of your posts and see this:

however, when I summarise it to 192.0.0.0,


but the issue is that 192.0.0.0 is not a summary, it is a network statement that identifies a single class C network (192.0.0.0).


What you are trying to do is supernetting and some protocols support that and some do not.


HTH


Rick

Actions

This Discussion