etherchannel between catalyst 4908G and 3750G (part 2)

Unanswered Question
Jan 4th, 2008
User Badges:

Sir EdisonOrtiz,


How are you Sir? I tried the configuration that you gave me but the problem is that 4908G switch wasn't recognized switchport command thus I cannot make the interface as trunk. So still I cannot connect to my 3750 switch. By the way the reason for BVI configuration was for routing. and for you to have a better feel of our switch configuration below is the configuration for both 4908G and 3750 switch. note: 4908G switch is the active.


4908G-L3 config:


bridge irb

!

!

!

interface Port-channel1

no ip address

no ip directed-broadcast

hold-queue 300 in

!

interface Port-channel1.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet1

no ip address

no ip directed-broadcast

!

interface GigabitEthernet1.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet1.10

encapsulation isl 10

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 10 priority 105 preempt

standby 1 ip 172.25.f.g

!

interface GigabitEthernet2

no ip address

no ip directed-broadcast

!

interface GigabitEthernet2.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet2.20

encapsulation isl 20

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 20 priority 105 preempt

standby 1 ip 172.25.f.g

!

--line omitted--

!

interface GigabitEthernet7

no ip address

no ip directed-broadcast

!

interface GigabitEthernet7.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet7.70

encapsulation isl 70

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 70 preempt

standby 1 ip 172.25.f.g

!

interface GigabitEthernet8

no ip address

no ip directed-broadcast

channel-group 1

!

interface BVI1

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 1 priority 105 preempt

standby 1 ip 172.25.f.g

!

router eigrp 200

network 172.25.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.25.d.e

!


bridge 1 protocol ieee

bridge 1 route ip

!

end



3750 switch config:


bridge irb

!

interface Port-channel1

hold-queue 300 in

!

interface GigabitEthernet1/0/1

no switchport

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

standby 10 ip 172.25.f.g

standby 10 preempt

bridge-group 1

no shutdown

!

interface GigabitEthernet1/0/2

no switchport

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

standby 20 ip 172.25.f.g

standby 20 preempt

bridge-group 1

no shutdown

!

--line omitted--

!

interface GigabitEthernet1/0/7

no switchport

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

standby 70 ip 172.25.f.g

standby 70 preempt

standby 70 priority 105

bridge-group 1

no shutdown

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

channel-group 1 mode on

no shutdown

!

interface BVI1

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip route-cache cef

standby 1 preempt

standby 1 ip 172.25.f.g

!

exit

!

bridge 1 protocol vlan-bridge

bridge 1 route ip

!

ip routing

router eigrp 200

network 172.25.0.0

no auto-summary

!

exit

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.25.d.e

!

end




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
chschroe Fri, 01/04/2008 - 23:38
User Badges:

I might be missing part of the story here, however, the 3750 does not support ISL.


Your subinterface configurations on the 4908G do, effectively, make those links trunks. You just need to change the encapsulation type to dot1q and give it a vlan identifier.


Do you really need to bridge in between all of them, or do you want to bond them together into an etherchannel? If so, you don't want bridging on at all. Just configure up all your ports in the etherchannel and apply your ip configuration to the port-channel.subinterface.


As to the Catalyst 3750, you definitely don't want to use BVIs - the platform doesn't actually support them, and you couldn't have ip addresses on all of those physical interfaces within a bridge group anyway, or all of that HSRP configuration or anything.


Set the individual ports to switchports, then you can set them as trunks that carry your VLAN identifiers, then you can assign just one ip address to each VLAN interfaces, for example one for interface vlan1, one for vlan10, and one for vlan20.


If you're not going to be using multiple vlans on an interface, you can just apply the ip information directly to an interface that has "no switchport" in it.


I am unsure as to what you'd like to do with the Etherchannels, I only see one interface in a channel group on each side. On the Catalyst 4908G, you basically will want one port-channel.subinterface for each VLAN you want to carry. On the Catalyst 3750 it depends, again, on exactly what you're planning to carry - you can either put several links directly into the port-channel and add ip information, or tie several trunks together and apply their ip information to their VLAN interfaces.


So, quick recap: 3750 only supports ISL, and does NOT actually support BVIs. Eliminate redundant IP addressing and apply it only to the BVI, subinterface, or VLAN interface where it is required. 3750 links can carry multiple VLANs by making them trunks and adding the VLAN ids.


Hope this helps a little.

agfernando Sat, 01/05/2008 - 00:21
User Badges:

First, thanks for your time and quick response. Well, to give you further info the objective of these 4908G and 3750 switches should be redundant to each other so that when one of the switch fails the other will be ready to take over and its function is to provide individual inter-vlan communication for each vlan.

Everything was working fine before until one of the two 4908G had failed and eventually replaced by 3750 switch. Now I cannot connect to 3750 switch and it doesn't establish a connection to my network when I tried to turn off the 4908G. The 3750 switch was suppose to provide the inter-vlan communication if the 4908G fails.

So, how do you think I would configure the 3750 to work as a reduntant switch to 4908G? And why do you think my 4908G doesn't support switchport command to set the port to trunk?


thanks.


chschroe Sat, 01/05/2008 - 00:56
User Badges:

You have to make your encapsulation dot1q on the 4908G! Good luck!


NS

Actions

This Discussion