Slow response with SSL (https) on CSS

Unanswered Question
Jan 4th, 2008


Our network topology is as per the attachement “CSS Topology Diag.jpg”. The users behind the CORE network will access the application through the VIP address “”. SSL card has been installed on the CSS's and the SSL gets terminated on the CSS. The traffic between CSS and the physical servers are on “http”.

Now when the users tries to access the application using SSL ( the application response is very slow, however when the users tries to access the application using http ( application response is ok.

Find the attached configurations of the primary and secondary CSS. Any inputs to resolve this issue..??

(Note: It take nearly 20 - 30 seconds to get the page when users initiate a connection through https and however when the users initiate the http connection page gets displayed in 2 - 3 seconds)


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Gilles Dufour Sat, 01/05/2008 - 03:18

Try the following commands

ssl-server X ssl-queue-delay 0

ssl-server X tcp server ack-delay 0

ssl-server X tcp virtual ack-delay 0

If the problem persists, get a sniffer trace on client side and server side simultaneous.


Gilles Dufour Sat, 01/05/2008 - 08:25

the traffic having issue is HTTPS not HTTP.

So we want to see a trace with HTTPS.

Also, get the trace on the client and on the server - not the CSS. (we want to see both side of the css)


rv_viji Sat, 01/05/2008 - 10:26

Hi Gilles,

I have attached the https logs in my previous reply to this post.

And regarding the server side trace, I will post it soon... however just to mention the ssl traffic (https)gets terminated on the CSS and from the CSS to the servers it is http traffic....


Gilles Dufour Sun, 01/06/2008 - 06:10

there is absolutely no SSL/HTTPS traffic in the 2 traces you sent. Only HTTP.

I would expect your client trace to contain SSL traffic.



This Discussion