L3 switch

Answered Question
Jan 5th, 2008
User Badges:

Hi,


I have two options to re-design the office (create 5 vlans).


1. router + ethernet switch (26xx + Dlink)

2. L3 switch, cisco CAT 35xx only (not cisco router)


which one is better? we will have 300 - 350 user within 3 years.


rgds


we have around 220 users.

Correct Answer by Jon Marshall about 9 years 6 months ago

Anita


You can use static routes on the 2800 or you can use a dynamic routing protocol such as EIGRP/OSPF to exhange routes between the 2 devices.


To connect the router to the 3750 it would make sense to use a L3 connection.


So on the 3750 under the interface you are connecting to the router


3750(config-if)#no switchport

3750(config-if)#ip address 172.16.1.2 255.255.255.252

3750(config-if)# no shut


On the 2800 router that connects to the switch


int fa0

ip address 172.16.1.1 255.255.255.252


The rest of the cat 3750 config is creating the vlans at Layer 2 and then creating the L3 interfaces


3750(config)# vlan 10


3750(config)# int vlan 10

3750(config-if)# ip address 172.16.2.1 255.255.255.0

3750(config-if)# no shut


you need to do this for each of your vlans. Note that until as least one port is active in the vlan the L3 vlan interface will stay down.


HTH


Jon

Correct Answer by paolo bevilacqua about 9 years 6 months ago

If it was only VLAN, sol. 2 is better.

But, in reality you always need a router to connect to internet, firwall, VPN, Voip, all things that only a router does.


So in practice you need both a good switch and a good router. For example, one 2800 router, one 3750 L3 switch, as many more CE-500 switches (because they have PoE for when you put the IP phones).

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (4 ratings)
Loading.
Danilo Dy Sat, 01/05/2008 - 09:38
User Badges:
  • Blue, 1500 points or more

Hi,


If its just a LAN (no WAN), I recommend option 2.


Regards,

Dandy

Correct Answer
paolo bevilacqua Sat, 01/05/2008 - 09:40
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

If it was only VLAN, sol. 2 is better.

But, in reality you always need a router to connect to internet, firwall, VPN, Voip, all things that only a router does.


So in practice you need both a good switch and a good router. For example, one 2800 router, one 3750 L3 switch, as many more CE-500 switches (because they have PoE for when you put the IP phones).

Richard Burts Sat, 01/05/2008 - 09:40
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Anita


There are some factors which might affect the design which you have not addressed in this post that could influence the design- for example is there a requirement for connectivity outside the office. But based on what you have provided so far I would advise the choice to use a Cisco layer 3 switch rather than a Cisco router connected to non-Cisco switch. If the primary routing activity is going to be inter-vlan routing then the layer 3 switch is a more effective solution than the router. With the router solution the frame must pass over the link from switch to router and then back over the same link from router to switch. Where with the layer 3 switch the frame arrives on one virtual interface and is routed out the other virtual interface.


HTH


Rick

anitachoi3 Sun, 01/06/2008 - 10:42
User Badges:

Hi


Thanks all, we may order cisco 28xx and csico 37xx.


If the vlan traffic goes through L3 switch, the router (28xx) should not be config 802.1q. am i right? I such config 5 static routes point to CAT 37xx.


the config should be:

R1:

!

interface FastEthernet0

ip address 172.16.1.11 255.255.255.0

ip nat inside

!

ip route 172.16.2.0 255.255.255.0

ip route 172.16.3.0 255.255.255.0

ip route 172.16.4.0 255.255.255.0

ip route 172.16.5.0 255.255.255.0

!

Interface FastEthernet1

ip address 209.x.x.x 255.255.255.252

ip nat outside

!

ip nat pool office 209.x.x.x 209.x.x.x netmask 255.255.255.252

!

ip nat inside source 10 interface FastEthernet1 overload

!

access-list 10 permit 172.16.0.0 0.0.7.255

!


what is the CAT 3700 config?


Rgds









Correct Answer
Jon Marshall Sun, 01/06/2008 - 11:03
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Anita


You can use static routes on the 2800 or you can use a dynamic routing protocol such as EIGRP/OSPF to exhange routes between the 2 devices.


To connect the router to the 3750 it would make sense to use a L3 connection.


So on the 3750 under the interface you are connecting to the router


3750(config-if)#no switchport

3750(config-if)#ip address 172.16.1.2 255.255.255.252

3750(config-if)# no shut


On the 2800 router that connects to the switch


int fa0

ip address 172.16.1.1 255.255.255.252


The rest of the cat 3750 config is creating the vlans at Layer 2 and then creating the L3 interfaces


3750(config)# vlan 10


3750(config)# int vlan 10

3750(config-if)# ip address 172.16.2.1 255.255.255.0

3750(config-if)# no shut


you need to do this for each of your vlans. Note that until as least one port is active in the vlan the L3 vlan interface will stay down.


HTH


Jon

Actions

This Discussion