IOS to be deleted

Unanswered Question
Jan 7th, 2008
User Badges:

Hi,


We are having Cisco 1751 router.In that i tried to delete the IOS but it was showing deleted in the brackets.


System flash directory:

File Length Name/status

1 4096 c1700-ipbasek9-mz.124-3b.bin [deleted]

2 5920708 c1700-y-mz.123-2.T2.bin

3 10852250 c1700-ipbasek9-mz.124-3b.bin [deleted]

[16777248 bytes used, 16777184 available, 33554432 total]

32768K bytes of processor board System flash (Read/Write)


when iam trying to load another IOS iam getting error message as sapce not available.Pls help to solve this issue.


regds

Nasheer

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
Jon Marshall Mon, 01/07/2008 - 02:45
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi Nasheer


You need to use the squeeze command to regain the space in your flash


1721# squeeze flash:


HTH


Jon

nasheer.ahmad Mon, 01/07/2008 - 02:59
User Badges:

Hi,


Iam getting the below error message


Squeeze operation may take a while. Continue? [confirm]

First create squeeze log by erasing the entire device


%Error squeezing flash (Missing or corrupted log)


regds

Nasheer

Farhan Jaffer Mon, 01/07/2008 - 04:17
User Badges:

Dear Nasheer,


To reclaim the space in Flash memory, use 'squeeze flash' command. If squeeze command is not working use 'erase flash' command. After completion, download your IOS back to the Router.


Note: Be sure, you have a console access when erasing flash. Just in case if router reboots while downloading IOS or erasing flash.


Richard Burts Mon, 01/07/2008 - 04:21
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Nasheer


I have encountered that error on 1700s. I am not clear about what causes it, but as the error message indicates you must erase flash (use the privilege level command erase flash:) and then you should be able to copy the new IOS into flash.


HTH


Rick

Kevin Dorrell Mon, 01/07/2008 - 04:27
User Badges:
  • Green, 3000 points or more

Rick,


Could it be that the error message occurs if you originally formatted the flash with the /no-reserve-squeeze-space option? (My syntax is not correct, but it is something like that).


I have some 2600s on which I have done that trick in order to get 12.2(15)T17 to fit in. What it does mean is that I cannot defragment the flash (a.k.a. squeeze). The message I get if I try and do so is similar to this one.


Kevin Dorrell

Luxembourg

Richard Burts Mon, 01/07/2008 - 04:43
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Kevin


That might be one reason for it. I did not use that option on these routers. So I am not clear whether there might be more than one cause or whether that option had been used on the routers before they got to me. I experience it on relatively few of the 1700s that I have worked with, so I do not think that it is generic to the platform or to the type of flash system that they use.


HTH


Rick

andychua.chua Mon, 01/07/2008 - 05:03
User Badges:

Sorry, i also face same problem as yours, the only solution is to erase flash, but make sure you have the console and you know how to copy IOS in ROMMON mode. this problem could be flash corrupt.

nasheer.ahmad Tue, 01/08/2008 - 23:04
User Badges:

Hi All,


The problem solved after erasing the falsh and uploading thru xmodem.

Thank you all for the support


regds

Actions

This Discussion