T1 Controllers

Answered Question
Jan 7th, 2008

Hopefully the answer to my problem will not be terribly obvious so as to make me look like a total newbie.

My company was 4 T1's between our corporate office and a branch office. On the corporate side is a Cisco 3640 and on the branch side is a Cisco 2620.

The 3640 has 4 T1 controllers but the 2620 only shows 2 when doing a "show controllers t1". My question is simply this:

If there are 4 controllers on one end, don't there have to be 4 on the other end? My fear is that the previous admin(s) never set our private lines up and we are not utilizing all of our T1's.

Thanks for any help or advice in advance.

Hopefully the answer to my problem will not be terribly obvious so as to make me look like a total newbie.

My company was 4 T1's between our corporate office and a branch office. On the corporate side is a Cisco 3640 and on the branch side is a Cisco 2620.

The 3640 has 4 T1 controllers but the 2620 only shows 2 when doing a "show controllers t1". My question is simply this:

If there are 4 controllers on one end, don't there have to be 4 on the other end? My fear is that the previous admin(s) never set our private lines up correctly and we are not utilizing all of our T1's.

Thanks for any help or advice in advance.

I have this problem too.
0 votes
Correct Answer by Richard Burts about 8 years 11 months ago

Christopher

Thanks for posting the output of the routing table. It makes me more comfortable that all 4 of the serial links are being used. A dynamic routing protocol like OSPF is much more effective at this than static routes would be.

HTH

Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (7 ratings)
Loading.
marikakis Mon, 01/07/2008 - 07:26

Hello,

Are you sure all the 4 T1's are supposed to be between the corporate office and a single branch? Or are there 2 of them going to one branch and the rest going to another branch? How many T1 ports does your branch 2620 have?

Also, note the state of the T1 controllers on the 3640. If they are up, then there should be some other router somewhere that cooperates with them.

Kind Regards,

M.

Christopher Bell Mon, 01/07/2008 - 07:35

We only have one branch, so they should all terminate on that end. 4 T1's between the 3640 and the 2620. The "show controllers T1" on the 3640 yields 4 T1 controllers. The same command on the 2620 only yields 2. I just don't know enough about the controllers and T1's to know if they are channelized or bound somehow so that only 2 controllers are needed on the 2620 end.

Thanks again for any help or advice.

amolwaghmare Mon, 01/07/2008 - 08:18

The 2 extra controller might have gone as a 2 serial links and not as controller on another end.Check and revert , we have same at office only the thing is that 1 controller is going to 20 locations with speed of 256 kbps

*******************************

RATE THE POST IF USEFUL

*******************************

Richard Burts Mon, 01/07/2008 - 08:34

Christopher

Several possibilities occur to me that might explain the number of controllers at the remote site:

- is it possible that the cards installed at the remote site support 2 serial links on each card so that only 2 are needed for 4 serial lines?

- is it possible that 2 of the links are connected to cards that supply the controller, and that the other 2 lines are connected to external CSU/DSUs and connect to serial ports on the router that do not have the controller on the router since it is using external CSU/DSU?

Posting the output of show diag (and possibly the output of show version) on the remote router might help to resolve this question.

HTH

Rick

Danilo Dy Mon, 01/07/2008 - 09:20

Hi,

From the "show diag" you have a total of 5 x T1 ports fully manage CSU/DSU.

In NM Slot0 you have two WIC Slots. In WIC Slot 0 with 1 port WIC-1DSU-T1= and in WIC Slot 1 with 2 ports WIC/VIC-T1,DUAL=

In NM Slot1 you have two WIC Slots. In WIC Slot 0 with 1 port WIC-1DSU-T1= and in WIC Slot 1 with 1 port WIC-1DSU-T1=

Regards,

Dandy

Richard Burts Mon, 01/07/2008 - 09:31

Christopher

Thanks for posting the output of show diag. There seems to be some difference between what show diag is indicating and whatever else you have been looking at. Show diag shows this:

Slot 0:

WIC Slot 0: WIC-1DSU-T1=

WIC Slot 1: WIC/VIC-T1,DUAL= (T1 (2 port) WAN daughter card)

Slot 1:

WIC Slot 0: WIC-1DSU-T1=

WIC Slot 1: WIC-1DSU-T1=

So it looks to me like 4 controllers one of which is capable of supporting 2 serial interfaces.

Can you reconcile this with the other information that you are looking at?

HTH

Rick

Christopher Bell Mon, 01/07/2008 - 10:00

Please see the attached output from the "show controllers t1" command issued on both routers. That is the part that is confusing me. I must admit my inexperience with WAN routing to date. To me ... the logical assumption would be there has to be the same number of T1 controllers on both ends.

From what you have pointed out above, each controller is/can be capable of supporting two T1's? Something like a NIC with dual ports?

Richard Burts Mon, 01/07/2008 - 10:08

Christopher

Thanks for the additional information. Even though the show diag indicates that there are 4 serial controllers in the remote router the show controller seems to indicate that only 2 of them are active.

Perhaps if you would post the output of show ip interface brief from both routers we might get some better insight into what is going on.

HTH

Rick

Christopher Bell Mon, 01/07/2008 - 10:16

Hi Rick,

The show ip interface brief output for both is attached. I see all the serial's up on both end. For some reason, it's not all comeing together for me as to "how" the t1's are configured.

amolwaghmare Mon, 01/07/2008 - 22:59

I think controller are not configured properly.Can you get the output of controller configuration so that it can be checked.

I think only controller card t10/1 and 0/2 are configured

Very Strange Case!

Christopher Bell Tue, 01/08/2008 - 03:39

Please see the output from "show run" for both routers attached, as it pertains to the serial interfaces and t1 controllers.

Thanks for your input and help. This is my first experience in these forums and it's more than I could have hoped for!

Attachment: 
amolwaghmare Tue, 01/08/2008 - 03:56

interface Serial1/0

ip address 10.1.102.2 255.255.255.0

ip load-sharing per-packet

ip route-cache flow

service-module t1 timeslots 1-24

service-policy output VidConf

!

interface Serial1/1

ip address 10.1.104.2 255.255.255.0

ip load-sharing per-packet

ip route-cache flow

service-module t1 timeslots 1-24

service-policy output VidConf

This are the remaining two T1 links for more details please go through

http://www.cisco.com/en/US/products/hw/modules/ps3129/products_tech_note09186a0080093d70.shtml

and to configure **Cisco Dual-Port T1/E1 Multiflex Voice/WAN Interface Card** you have to use the following configuration

controller T1 0/1

framing esf

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 0/2

framing esf

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

For more details please go through:

http://www.cisco.com/en/US/docs/ios/12_1t/12_1t1/feature/guide/dtg703.html

Hope this helps , Thanks!

************************************

RATE USEFUL POST

*************************************

Christopher Bell Tue, 01/08/2008 - 04:04

When you say "This are the remaining two T1 links for more details please go through..." are you implying that we are NOT using all of our T1's properly? Im confused by your post. Please expound a little in laymans terms if possible. It looks like the T1 controllers are configured exactly as you have layed out above ...

controller T1 0/1

framing esf

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 0/2

framing esf

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

Richard Burts Tue, 01/08/2008 - 04:36

Christopher

I believe that your 4 T1s are being utilized. In particular I believe that the output of show ip interface brief which you posted shows 4 normal serial interfaces with valid IP addresses and all in the up/up state. If we want to verify that they are being used then I would suggest that posting the output of show ip route from at least the branch router could indicate that there are routes using each of the interfaces. The output of show interface for the serial interfaces could show the number of input and output packets which would show usage. And traceroutes from the branch to various destinations could show traffic flowing over the various interfaces.

It seems to me that perhaps we should step back and clarify what the question is because I believe that we are really talking about 2 slightly different things. One question is are the serial interfaces really being used (and that part of the question has not really been addressed so far) and the other question is about the configuration of the controllers and interfaces (which has been the focus so far - and shows some inconsistency).

I believe that the question of usage of the serial interfaces is fairly straightforward and can be addressed with the outputs that I have suggested. The question of configuration is more of a puzzle. The output of show diag on the branch seems to show the same part number (WIC-1DSU-T1=) for controllers in slot 0 and in slot 1. But they are not configured the same: the controllers in slot 0 are configured with explicit controller t1 commands while the controllers in slot 1 are configured with service-module t1 commands. I am a bit puzzled why cards that seem to have the same part number are configured differently but I believe that both forms of configuration are valid and produce serial interfaces that work.

I do not believe that the confusion about how they are configured should cast doubt on the operational state of the serial interfaces.

HTH

Rick

Christopher Bell Tue, 01/08/2008 - 04:45

Hi Rick,

Thanks for clarifying. If you would have been within 10 feet of me, you would have heard a big sigh of relief.

The sh ip route fromthe 2620 (branch office) does indeed show 4 directly connected serial interfaces, which I assume represent our T1 lines:

C 10.1.104.0/24 is directly connected, Serial1/1

C 10.1.103.0/24 is directly connected, Serial0/2:0

C 10.1.102.0/24 is directly connected, Serial1/0

C 10.1.101.0/24 is directly connected, Serial0/1:0

I'll verify traceroutes today. In the past when I have done this, I've only seen traffic flowing over the 10.1.104.0 net... not the others. I assumed that this was because they were "bound" somehow, but now I have to wonder.

I've also cleared the stats on the interfaces so I can monitor the input and output packets.

Stay tuned..

Richard Burts Tue, 01/08/2008 - 05:05

Christopher

The 4 "C" routes are indeed the 4 connected interfaces. What I would really like to see in the routing table is whether there are other routes which use the different serial interfaces as the next hop. I am not clear whether these routers are using static routes or some dynamic routing protocol. If the routing table is not large would it be possible to post the entire table?

Clearing the counters and then monitoring is a good step in evaluating the usage of the several serial links. As I look at the config I notice that the serial interfaces are configured with ip route-cache flow. So you might be able to use NetFlow to check on usage.

Your mention of the interfaces being bound brings up an interesting point. I am not seeing anything so far that indicates that they are bound and it appears that they are configured independently and would be doing load sharing. There is a possibility that you might consider which is to configure multilink on the routers. PPP multilink takes serial links and shares the traffic over the links. Your environment would appear to be a good candidate for configuration of multilink and that would assure usage of all the links.

HTH

Rick

Christopher Bell Tue, 01/08/2008 - 05:19

Hi Rick,

Attached is the output from "show ip route" on the branch office 2620. We use OSPF for our routing protocol. I see the learned routes and each route is indicated seperately over the each serial link (in effect there are 4 routes to each subnet). From what I can gather from your post above, configuring PPP multilink rather than load balancing would be make more efficient use of our bandwidth?

I'll "google" using Netflow, and configuring PPP multilink .

Thanks again!

amolwaghmare Tue, 01/08/2008 - 05:28

Hi,

I have already posted that this are two different card and you need to configure them differently .Please go through link which i have mentioned

Correct Answer
Richard Burts Tue, 01/08/2008 - 05:37

Christopher

Thanks for posting the output of the routing table. It makes me more comfortable that all 4 of the serial links are being used. A dynamic routing protocol like OSPF is much more effective at this than static routes would be.

HTH

Rick

Actions

This Discussion