Routing and bridging on the MAR3200

Unanswered Question
Jan 7th, 2008

Hi,

I use a MAR3200. The port of the MARC (F0/0) and one port of the switch card (FESMIC F2/1) are connected to 2 devices belonging to the same subnet. IRB is enabled and a BVI is defined.

PCA is connected to F0/0, PCB is connected to F2/1.

When PCA sends a ping request to PCB, PCB answers but the answer does not reach PCA.

When PCB broadcasts an ARP request before a ping to PCA, the PCA answer reaches PCB. Then PCB sends a ping request to PCA but the request does not reach PCA.

Bridging looks operating properly (?) but not routing. What is mising in my configuration (see a short extract below).

Thanks by advance

Alain-Claude

no spanning-tree vlan 3

!

bridge irb

!

!

interface FastEthernet0/0

no ip address

speed auto

full-duplex

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet2/1

switchport access vlan 3

!

interface Vlan3

no ip address

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.231.85.249 255.255.255.248

no ip route-cache

!

no ip classless

ip forward-protocol nd

!

bridge 1 protocol ieee

bridge 1 route ip

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Hi, your BVI interface looks good, but if you want to route for vlan3 you need to enable dot1Q on your ethernet0/0 interface , you have the bridge-group 1 command on that interface, try adding "encapsulation dot1Q 1" on ethernet0/0. i was just tasked with adding several BVI interfaces on our network and had to overcome some bridge-group problems myself. HTH

interface FastEthernet0/0.9

encapsulation dot1Q 222

no snmp trap link-status

bridge-group 222

interface FastEthernet0/1.9

encapsulation dot1Q 222

no snmp trap link-status

bridge-group 222

interface BVI222

description Quarantine Data Vlan

ip address 2.222.44.1 255.255.255.0

bridge 222 protocol ieee

bridge 222 route ip

route-map quarantine 10

match interface BVI222

set ip next-hop 2.222.254.1

martec_acbarcelo Wed, 01/09/2008 - 10:18

Thanks Donald for your answer. I tried your suggestion but results are not so good. Pings from MAR to PCA on f0/0 operates properly. Pings from MAR to PCB on f2/0 does not work. PCB receives the ping request and replies, but the MAR does not receive it. "debug ip icmp" provides no trace.

I attach the configuration file <>. It should be nice if you can have a look.

thx - Alain-Claude

Attachment: 

Actions

This Discussion