UC500

Answered Question
Jan 8th, 2008

Hi, does anyone know the cli command to reset the UC500 back to its factory defaults?

I have this problem too.
0 votes
Correct Answer by Brandon Buffin about 8 years 11 months ago

You can find the default configuration files here:

http://www.cisco.com/cgi-bin/tablebuild.pl/UC520-files

Once you download the config file, copy it to the UC520 and use the "conf replace" command to replace the current config with the default config.

Hope this helps. If so, please rate the post.

Brandon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
cooper505 Tue, 01/22/2008 - 12:08

I have the same issue knid of.

We were changing some extension numbers on the UC500 and saving the config to the UC500 via CCA. I had an Java error when saving the config so it has not completed the update.

We can now no longer see the device through CCA or ping it on the network.

We have rebooted the UC500 but to no avail.

Does anyone know if there is an hardware reset procedure to reset the config back to default! Hopefully we will then be able to get into our device.

Brandon Buffin Tue, 01/22/2008 - 12:12

Connect to the UC500 using a console cable and a terminal emulation program. Download the original config files mentioned in my previous post and use the "config replace" command to replace the current config with the original.

Hope this helps.

Brandon

cooper505 Tue, 01/22/2008 - 12:33

Hi bbuffin

Thanks for your reply, i am pleased i havent tottaly knacked the system.

I am new to Cisco UC devices so have not done much work on them.

Do you know the commmand/s i would need and what file/s would have to be changed to get it to boot up with the default factory config and ip address's

Any help would be greatly received

Thanks for your help

Cooper

Brandon Buffin Tue, 01/22/2008 - 13:03

Cooper,

1. Connect to the console port on the router. The following link show you how to connect to the console port of the UC520.

http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a008010ff7a.shtml#connecttermtocat

2. After following the link in my previous post, download the factory config zip file for your version.

3. Copy the correct config file found inside the zip file you downloaded to a FTP server.

4. On the UC520, issue the "copy ftp flash" command and follow the prompts to copy the config file to flash memory.

5. Use the "config replace" command to replace the current config with the downloaded config, such as:

router#conf replace flash:UC520W-16U-4FXO-K9-factory-4.2.5.cfg

6. Copy the running cofig to startup conifg with the "wr mem" command.

Hope this helps.

Brandon

cooper505 Tue, 01/22/2008 - 13:52

bbuffin,

Thanks for your assistance on this issue.

Just thinking ahead till tomorrow when I try this, will the UC500 be able to see an FTP server as the device does not have an IP address associated with it due to the config saving problem we had? So it may not be able to see anything on our subnet.

Could we then copy the factory config file direct to the compact flash memory card installed in the front of the system and write from there?

I also have a complete copy of all the files on the compact flash card before the system was powered on, would these help? Just a thought.

Thanks for all your help regarding this again.

Thanks again

Cooper

Brandon Buffin Tue, 01/22/2008 - 13:59

Cooper,

You're right, it's possible you won't be able to access an FTP server. Yes, you can copy the file to the flash and copy from there. The original config would not have been on the flash.

Brandon

cooper505 Tue, 01/22/2008 - 14:25

Hi Brandon

I will try in the morning. What I will need to do is:

1.Use the "config replace" command to replace the current config with the file on the flash card, such as:

2.router#conf replace flash:UC520W-32U-4BRI-K9-factory-4.2.5.cfg

3.Copy the running config to startup config with the "wr mem" command.

Just to confirm

Thank you again for all your help regarding this

Cooper

cooper505 Wed, 01/23/2008 - 09:04

Hi Brandon

That all worked fine!!

Thank you so much for all you assistance on this it worked a treat.

Managed to get the default IP back in the system so that a could change the other settings needed.

The system is kind of working now but for an error

Error: Voice

For input string: "GB"

When we run the CCA voice setup and it queries the phones.

I think this is to do with the fact that we changed the locale for the system to UK with these files.

CME-Local-en-UK_4.1.0.0.tar

CUE-vm-en-GBlang-pack-2.3.4.1.prt1

Cue-vm-lang-pack.2.3.4.1.prt1

Via CCA and all went fine, until we try and connect again, then we get the error.

Dont surpose you are a genius on this subject as well? Here's to hoping!

Thanks again for all you help

Regards

Dan

Brandon Buffin Wed, 01/23/2008 - 10:18

Dan,

I'm glad all went well with the config restore process. Unfortunately, I'm not familiar with this error or really with CCA. You might try opening a TAC case on this one.

Brandon

Actions

This Discussion