IPv6 With eui-64 over Frame-Relay

Unanswered Question

Hi Experts!

i have 2 routers connected togather via frame-relay link IPv4 and IPV6.AM OK with ipv4 but not with IPV6.have a look to the config plz:


interface Serial1/0

ip address

ip nat inside

ip virtual-reassembly

encapsulation frame-relay

ipv6 address 2001:ABC:123:36::/64 eui-64

serial restart-delay 0

no dce-terminal-timing-enable

frame-relay map ipv6 2001:ABC:123:36:20F:F7FF:FE68:6470 603

frame-relay map ip 603 broadcast

frame-relay map ip 603

frame-relay map ipv6 FE80:20F::F7FF:FE68:6470 603 broadcast

no frame-relay inverse-arp



interface Serial1/0

ip address

encapsulation frame-relay

ipv6 address 2001:ABC:123:36::/64 eui-64

serial restart-delay 0

no dce-terminal-timing-enable

frame-relay map ipv6 FE80::212:7FFF:FE28:7100 306 broadcast

frame-relay map ip 306

frame-relay map ip 306 broadcast

frame-relay map ipv6 2001:ABC:123:36:212:7FFF:FE28:0 306

no frame-relay inverse-arp


1)what this and in wich cases we need it:eui-64

2)what this map mean:frame-relay map ipv6 FE80::212:7FFF:FE28:7100 306 broadcast


from where this coming from:212:7FFF:FE28:0

many 10xs to ur explanations

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Edison Ortiz Tue, 01/08/2008 - 12:31

eui-64 will complete the IPv6 addresses with information from the interface MAC Address. Very useful on avoiding duplicate IPv6 addresses in a network as most MAC addresses tend to be unique per interface.

I don't recommend using it on frame-relay interface because of the frame-relay mapping. You need to go into the remote router and type show ipv6 int bri to find the whole MAC address and then use that information in your local router for the mapping. Way too many steps...

On the second question, you need to map the link-local address of the remote router in addition to the IPv6 address for dynamic routing protocols.

On the third question, the :212:7FFF:FE28:0 is the node address, usually derived from the interface MAC address.

hi edison


could you plz configure this via Vlan access-list

VLAN Access Control

Configure an ACL with name “y” to obtain the following requirements:-

- Deny Web Traffic from to Subnet

- Permit Web Traffic from to Subnet

- Permit Any Other ip traffic from your Rack to Subnet

Do not Use deny Statements, use only PERMIT statements.

( is VLAN_200)



royalblues Tue, 01/08/2008 - 12:38

1. Interface identifiers (IDs) in IPv6 addresses are used to identify a unique interface on a link and are sometimes referred to as the "host portion" of the IPv6 address.

For Ethernet, the interface ID is

based on the media access control (MAC) address of the interface, in a format called the extended universal identifier 64-bit (EUI-64) format. The EUI-64 format interface ID is derived from the 48-bit MAC address by inserting the hexadecimal number FFFE between

the organizationally unique identifier (OUI) field (the upper three bytes) and the vendor

code (the lower three bytes) of the MAC address. The U/L bit of the first byte is also inverted

2. Shows the frame-relay map where the IPv6 address FE80::212:7FFF:FE28:7100 is mapped to DLCI 306. Broadcast keyword allows the DLCI to forward broadcast and multicast packets, a necessity when using link state routing protocols like ospf

3. 212:7FFF:FE28:0 -- as in point#1 derived from the mac address and inserting FFFE to get the interface identifier



royalblues Tue, 01/08/2008 - 12:55

Not sure how the vlan acccess-list relates to the above post but i think the below config should work

ip access-list extended VLAN_ACL_drop

permit tcp eq www

ip access-list extended VLAN_ACL_accept

permit tcp eq www

permit ip any

vlan access-map Y 10

match ip address VLAN_ACL_drop

action drop

vlan access-map Y 20

match ip address VLAN_ACL_accept

action forward

vlan filter Y vlan-list



royalblues Wed, 01/09/2008 - 23:14


It is a normal access-list

I used "TCP" and restricted only the www traffic. If you want you can use "ip" instead but this will block all access between the hosts



simaskvilius Tue, 01/08/2008 - 14:17

1) EUI-64 is a method used to automaticlly create unique host portion of IPv6 address (last 64 bits of IPv6 address). EUI-64 takes MAC address from router (Router has additional pool of MAC addresses in case if interface is not Ethernet interface) and inserts FFFE hex value into the middle of the MAC address.

2) It is link-local address (IPv4 has no equivalent to IPv6 link-local address). Link-local addresses always begins with prefix FE80::/10 and ends with EUI-64

3) It is ordinary unicast IPv6 address, 212:7FFF:FE28:0 is formed by EUI-64


This Discussion