Frame Relay ISSUES :( HELP ME PLEASE!!!!

Unanswered Question
Jan 9th, 2008

Hello Guys,

I am attempting configure Frame Relay on my 2 router. I have 2 serial cards only. Evidently I am not doing something right. I need to know if anyone has any documentation on how to configure a point to point using Frame Relay between 2 routers? Thanks. I have tried and can't PING HELP!!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Wed, 01/09/2008 - 13:40

Charlie

I am not sure from your post whether you are trying to configure routers with a real serial link as Frame Relay or if you are are trying to configure routers back to back as Frame Relay. Since the configuration of a real serial link is easy and examples abound I am assuming that you are trying to do it back to back. It has been a while since I have done that, but my memory is that you need to configure both interfaces as encapsulation frame-relay, you need to configure both interfaces to use the same DLCI, and you need to configure the interfaces with no keepalive (since you do not have anything to generate LMI and LMI is the essential part of keepalives in Frame Relay). Of course you also need to take care of things like clock-rate on the router that will be the physical DCE.

HTH

Rick

Charlie Mayes Wed, 01/09/2008 - 13:46

I am attempting to configure a back to back.

Router2

config

Current configuration : 590 bytes

!

version 12.3

no service password-encryption

!

hostname Router2

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/2/0

no ip address

encapsulation frame-relay

frame-relay lmi-type ansi

!

interface Serial0/2/0.123 point-to-point

ip address 192.168.1.2 255.255.255.252

frame-relay interface-dlci 122

!

interface Serial0/2/1

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

!

!

!

line con 0

line vty 0 4

login

!

!

end

Router1 config

Current configuration : 608 bytes

!

version 12.3

no service password-encryption

!

hostname Router1

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/2/0

no ip address

encapsulation frame-relay

frame-relay lmi-type ansi

clock rate 56000

!

interface Serial0/2/0.122 point-to-point

ip address 192.168.1.1 255.255.255.252

frame-relay interface-dlci 122

!

interface Serial0/2/1

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

!

!

!

line con 0

line vty 0 4

login

!

!

end

Richard Burts Wed, 01/09/2008 - 13:51

Charlie

The biggest issue that I see is the

frame-relay lmi-type ansi

under both serial interfaces. Since there is nothing in your back to back connection that will generate LMI, you have told your routers to expect to receive ANSI LMI and when they do not receive it the line protocol stays down. Try removing the frame-relay lmi-type ansi and confiure no keepalive and see what happens.

HTH

Rick

Actions

This Discussion