network connectivity on a PIX 515E

Unanswered Question
Jan 10th, 2008

Hello, I'm having serious issues getting a PIX 515E seen on the network to perform a password recovery. I set the address, gateway, and server address. Setup the tftp server, but iI cannot ping the device. Any sugestions?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
larryfocust Thu, 01/10/2008 - 12:56

yes, I'm trying interface 0, all ping requests time out. Also yes, I am trying to use that procedure, but until i can connect........ nothing doing

adam.sellhorn Thu, 01/10/2008 - 13:55

Interesting, I just pulled one of my old 525's down and tried this with the same result you seem to be getting. I ended up having to not specify a gateway address to get this to work. After configuring the interface, address, server, and file on the PIX I was only able to ping from my PIX to the tftp server and not the other way around...

My configuration (FYI):

tftp server address

PIX interface 0 address

larryfocust Thu, 01/10/2008 - 14:59

Adam, i configure

interface 0 to



i cannot ping to or from it but it tries to read np63.bin from tftp server. Though i get the message: cannot read specified file each time it tries to connect............any suggestions?

adam.sellhorn Thu, 01/10/2008 - 15:15

Since you cannot specify a subnet mask the PIX will assume a classful network mask for you. In your case it will be (192.x.x.x = Class C). So using an interface IP of 192.168.70.x and a server IP of 192.168.42.x you would have to use a default gateway. What I would recommend trying is installing a tftp server, like pumpkin, on a laptop or PC and plugging directly into your PIX, interface 0, and configuring your two devices to be in the same subnet.

larryfocust Fri, 01/11/2008 - 10:24

Adam, I have setup a laptop using the same config as you did but I keep getting the same errors."TFTP Failed (return:-10 arg:0x2)" in Hyperterminal, and "Could not open requested file for reading" on the TFTP Server.

adam.sellhorn Fri, 01/11/2008 - 12:07

At this point I can only guess that maybe it's a permissions issue on the np63.bin file itself. Can you verify that your TFTP server has read access to this file?

larryfocust Fri, 01/11/2008 - 12:13

Adam, I just got it.For some reason i tried another tftp server and it worked. Though I couldn't ping to or from (very strange). But I can't thank you enough for all you suggestions and help.



This Discussion