PBR help needed

Unanswered Question
Jan 10th, 2008

What would the pbr policy be using 6506 switch

I need to create a pbr on an interface vlan that checks this:

If traffic is destined for 0.0.0.0 then set the next hop to router A, else continue as normal?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Thu, 01/10/2008 - 15:14

Hi

Are you sure that this is the address you want to route to because you shouldn't get packets with this as a destination address.

Jon

Edison Ortiz Thu, 01/10/2008 - 15:17

You are looking for the set ip default next-hop instead of the set ip next-hop.

The set ip default next-hop will examine the routing table first and if destination address isn't there, it will use the PBR for the next hop while the set ip next-hop will use the PBR first and routing table second.

HTH,

__

Edison.

cisconoobie Thu, 01/10/2008 - 15:36

Thanks but what if I already have a default route in the routing table that already points to for example 192.168.2.1 and I want the default route changed specifically for hosts on vlan 200 to 192.168.3.1.

All other vlans, 100 and 300 will use the default route of 192.168.1.1

Any ideas? And keep pbr routing in hardware and not in software?

cisconoobie Thu, 01/10/2008 - 19:31

I'm still kind of confused why it would not use the default route thats in the routing table.

The definition for this is as follows:

default next-hop: Sets next hop to which to route the packet if there is no explicit route for this destination.

If I create this:

Routing table

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

O 192.168.1.0/29 [110/2000] via 192.168.1.1, 1d01h, Port-channel18

O 192.168.3.0/29 [110/2000] via 192.168.3.1, 1d01h, Port-channel28

C 192.168.2.0/24 is directly connected, Vlan200

C 192.168.4.0/24 is directly connected, Vlan400

S* 0.0.0.0/0 [1/0] via 192.168.1.1, 1d01h, Port-channel18

access-list 1 permit 192.168.2.0 255.255.255.0

interface vlan 200

ip address 192.168.2.1 255.255.255.0

ip policy route-map new_route

route-map new_route permit 10

match ip address 1

set ip default next-hop 192.168.3.1

If the route map gets processed for a packet with source address 192.168.2.25 and destination of 66.66.66.66, your saying that it should ignore the static route of 192.168.1.1 and proceed to 192.168.3.1 ???

cisconoobie Thu, 01/10/2008 - 19:59

I read that article but am confused how this access list would look in my situation?

Are extended access lists allowed in route maps?

Looking at my last post, how can I make the pbr work so that the packet get forwarded to 192.168.3.1 instead of 192.168.1.1 ??

s.arunkumar Thu, 01/10/2008 - 20:21

i am not sure if deny works with pbr ,but 4rm my logic..

access-list 100 permit any 192.168.0.0 0.0.0.255

access-list 100 deny any 192.168.0.0 0.0.3.255

access-list 100 deny any 192.168.4.0 0.0.0.0

access-list 100 permit any any

(( as u have entry in routing table 4 192.168.1.0-192.168.4.0 and rest is consideras default here))

apply this to ur pbr..

Edison Ortiz Fri, 01/11/2008 - 12:59

You tried and it didn't work?

Care to post debugs from the PBR?

I don't have the time to duplicate your environment at the moment hence the questions.

Thanks

Actions

This Discussion