CME - No Local Directory on 7905/7912

Unanswered Question
Jan 10th, 2008

We've been running CME for a while here now, but for some reason, the Local Directory refuses to display on the 7905 and 7912 phones. This has remained consistent through different phone firmware versions and CME upgrades.

The directory works fine on the 7940 & 7960 phones, but on the 7905 & 7912s, there is no "Local Directory" option - just "missed calls", "received calls", "placed calls" and "speed dial".

One thing I've noticed is that on the 7940/7960, the directories URL is visible under settings - http://x.x.x.x:80/localdirectory whereas on the 7905/7912, it's blank.

Forcing this directories URL under the telephony-service config makes no difference.

Is the local directory supposed to be supported on the 7905/7912? Any hints as to why it may not be working?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Sun, 01/13/2008 - 06:56

Hi, which FW are running on the phones ?

You should run 8.0(2) only. Many other version have bugs with the local directory.

Hope this helps, please rate post if it does!

b.henshaw Sun, 01/13/2008 - 15:46

Thanks for the reply.

We were running 8.0.1

Not sure exactly which file 8.0(2) is, but I just tried 8.0.2 (CP7905080002SCCP060817A.sbin) from and this gave me no love.

Is 8.0(2) == 8.0.2 or is it closer to 8.0? Any hints as to which CME zip/tar file I can find it in?

Paolo Bevilacqua Mon, 01/14/2008 - 00:16

Hi, 8.0.1 has a the missig LD bug as mentioned above. Download 8.0.2 from 79xx firmware area, not the ccme tar files.

Hope this helps, please rate post if it does!

b.henshaw Mon, 01/14/2008 - 15:46

Thanks for the further advice. I just tried 8.0.2 and 8.0.3 from the 7900 firmware download area and these also had the same problem - no directory and the directory URL setting under network configuration is blank.

I should correct my earlier post also - these are 7905G & 7912Gs - not 7905/7912's - though I expect this makes little difference. (yes, I've been loading the G firmware)

Paolo Bevilacqua Tue, 01/15/2008 - 01:31


Definitely I do not see the problem with 8.0.2, while 8.0.3 has it.

Anyway, now 8.0.4 is out and the bug even got an ID: CSCsl96231

I've loaded it for a try and LD is OK.

Verify that the FW you intended to load is correctly loaded from settings -> device status.

b.henshaw Tue, 01/15/2008 - 18:26

How odd.

I notice that bug only lists the 7912 - I will try the same updates (with 7912G firmware) in the next couple of days and see if this helps - to date I've only been dealing with the 7905s.

The firmware is loading correctly on the 7905 with each change - I can see it download the new image from tftp and when I check the running version under settings, it changes to the version I expect.


This Discussion