Duplex mismatch

Unanswered Question
Jan 10th, 2008


I am using cisco call manager 4.1(3), problem is IP phones specially 7902 are connected with Linksys & cisco 3750,2950 switches but in router log it is showing "%CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on gigabit ethernet port " though i have checked the duplex settings of phone and switch port.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Kevin Dorrell Fri, 01/11/2008 - 01:52

Can you be a bit more specific about how these connections are made?

Are you using a transparent switch that does not support CDP? (For example the linksys). If this is the case, then the duplex will be determined independently between the phone and the linksys, and between the linksys and the real Cisco. But the CDP will pass transparently. In those cases you can get spurious duplex mismatch messages.

Can you provide more details about the physical connections please?

Kevin Dorrell


s-adhikary Fri, 01/11/2008 - 05:11

Thanks for your reply

But my question is if real mismatch is not there the why log is saying like this , brief connectivity is like , centralize CCM is connected with different cisco 3750 and 2950 and linksys switches used for distributing all cisco phone , one thing is there cisco 7940 is not creating any problem but cisco 7902 is creating such kind of logs

Kevin Dorrell Fri, 01/11/2008 - 05:39

I'm still not clear about your architecture, but let me explain how you can have a spurious duplex mismatch message. Suppose you have a connection like this:

Phone <---> linksys <---> 3750

(I'm not saying that is how you are connected, but I am just illustrating. I don't understand yet how you are connected.)

Now, you could imagine a situation where, for example, the link between the phone and the linksys is working in full duplex, and the link between the linksys and the 3750 is in half-duplex. But the linksys passes the CDP transparently, not understanding what it is. So the phone hears the message "Hello, I'm a 3750 and I am working in half-duplex". While the 3750 hears a message "Hello, I'm a Cisco phone and I'm working in full-duplex." Both are correct, but both beleive that the CDP partner is getting it wrong.

The only way you can be sure is to look at show cdp neighbor detail.

So could you show us a diagram of you connections please? And the interface configurations on the links that are showing these messages.

Kevin Dorrell


Kevin Dorrell Sat, 01/12/2008 - 04:11

So, as I thought, you have the phones connected to the 3750 via a Linksys switch. The link between the 7902 phone and the Linksys is running half-duplex, and the link between the Linksys and the 3750 is running full-duplex. The reason for the messages is that the Linksys is pasisng CDP transparently. This makes the 3750 and the 7902 believe they are directly connected, so they mistakenly believe there is a duplex mismatch.

The error message is not real, so in that sense your problem is cosmetic. What can you do about it? I don't know much about the 7902, but in general terms these are your options:

1. Configure the 7902 to autonegotiate the duplex, in which case it will become full-duplex. (Note: forcing full duplex on the 7902 will not do the trick because it will disable autonegotiation, so the Linksys will fall back to its default, which is half-duplex.)

2. Disable the CDP at the 3750. I don't know whether that would generate some real problems between the phone and the 3750, however.

3. Disable message logging (a.k.a. turn a blind eye.) Not recommednded.

4. Put up with the messages.

5. Get rid of the Linksys switches and buy something that understands CDP.

6. Put the phones directly on the ports of the 3750.

Now, I presume that phones connected directly to the 3750 do not suffer this problem. But if they do, it is because you have configured the phone to do full duplex. This disables autonegotiation so the 3750 becomes half-duplex, and therefore mismatch. Instead, you do best to have both sides of the link autonegotiate, or both sides forced, but not a mixture.

Hope this helps.

Kevin Dorrell



This Discussion