problem with tha call CallManager & Nortel (CS1000)

Unanswered Question
Jan 11th, 2008
User Badges:

I have a communication between two sites, where one site is CallManager and the other site is PBX Nortel, then when I call form CallManager the call cuts off to the 3 minutes, please i need help you, what`s the problem?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
pcameron Sun, 01/13/2008 - 14:25
User Badges:
  • Cisco Employee,

I am assuming you are using H323 here. We have seen this problem in the past - 3 minutes (180 seconds) is a 'magic' number for TCP keepalives between the devices.


We had a lot of customers see a similar issue some time back with the CCM server running Trend Micro antivirus software. Apparently the application also includes a 'personal firewall' that by default would allow the H225 and H245 traffic through, but would block the TCP keepalive traffic. If you are running anything like this, turn off the firewall service.


If you are not running the Trend micro app, it is still likely there is something between the two devices that is blocking the TCP keepalive traffic and this is what is causing the calls to drop.


felixlino Wed, 01/23/2008 - 06:58
User Badges:

Please what`s mean:


*Jan 17 20:56:09.871: htsp_timer_stop3

*Jan 17 20:56:09.875: htsp_process_event: [0/2/0, EM_WAIT_FOR_ANSWER, E_HTSP_RELEASE_REQ]em_wait_answer_release

*Jan 17 20:56:09.875: em_stop_timers

*Jan 17 20:56:09.875: htsp_timer_stop

*Jan 17 20:56:09.875: htsp_timer_stop2 em_onhook (0)

*Jan 17 20:56:09.875: [0/2/0] set signal state = 0x0 timestamp = 0

*Jan 17 20:56:09.875: em_start_timer: 400 ms

*Jan 17 20:56:09.875: htsp_timer - 400 msec

*Jan 17 20:56:10.275: htsp_process_event: [0/2/0, EM_GUARD_ALL, E_HTSP_EVENT_TIMER]em_guard_all_timer

*Jan 17 20:56:10.275: em_stop_timers

*Jan 17 20:56:10.275: htsp_timer_stop

*Jan 17 20:56:10.275: em_start_timer: 3000 ms

*Jan 17 20:56:10.275: htsp_timer - 3000 msec

*Jan 17 20:56:10.275: htsp_process_event: [0/2/0, EM_PARK, E_DSP_SIG_0000]em_park_onhook

*Jan 17 20:56:10.275: htsp_timer_stop

*Jan 17 20:56:10.275: htsp_timer_stop2 htsp_report_onhook_sig


That`s event in the moment the call is cutoff

pcameron Sun, 01/27/2008 - 03:40
User Badges:
  • Cisco Employee,

Ok ... so you are using analogue E&M ports - wish you had told us this earlier.


The Nortel is not giving answer supervision to signal the router the call was actually picked up. As a reuslt, IOS wait the three minutes and then decides that since it never got an indication of the answer, there is no point in keeping up the IP side.


You can see this in the debugs -


Jan 17 20:56:09.875: htsp_process_event: [0/2/0, EM_WAIT_FOR_ANSWER, E_HTSP_RELEASE_REQ]em_wait_answer_release



The router was in the wait for answer state, then it went to the on hook state further in the debugs.


The solution is simple - add the following command under voice-port 0/2/0 :


auto-cut-through


This tells IOS to send an immediate answer on the IP leg and ignore the need for an answer signal from the external PBX.


The other option is to get the PBX programmed correctly to provide the answer signal.


felixlino Mon, 01/28/2008 - 06:53
User Badges:

Sincerely Thank you,

This problem was solved


Thank


Actions

This Discussion