Unity 4.0(3) & Exchange 2003 & Exchange 2007

Unanswered Question

We have a Unity 4.0(3) box integrated with an Exchange 2003 server. We have added an Exchange 2007 server.

We had some advice from our Cisco reseller that we could do this and then move the mailboxes of subscribers to the 2007 server. It was supposed to work like this: As long as we left the 2003 server integrated with the Unity 4.0(3) SR1 box, the 2003 server would forward the voice messages to the 2007 box where the subscriber mailboxes were homed.

Now, for 200+ users, this is working perfectly. For 79 users, it isn't. They get a message that the email server is down when the log in by phone. There messages are still collected and they can listen to them by phone.

So far, the difference that I have noted for the 79 users is that the Exchange server listed on the Unity administration page is the 2007 server. For the working users, the 2003 server is still listed. So far, that is the only distinguishing factor.

Is there a way for me to force the Unity 4.0(3) box to only look at my 2003 server?

If Unity is pulling this property from Active Directory, what is the property name?

I really don't want to move the mailboxes back to the 2003 box since most of the users are working.

I did open a case with TAC but so far, they are saying it isn't s supported configuration. Well, I guess I have to accept that but I can't keep from noting that the 200+ users are working...

We plan on upgrading to Unity 5 in the summer so we just need a workaround for a few months.

Thank You!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)

It turns out something is setting the HomeServer in the Subscriber table to the 2007 server. If we set it back to the 2003 server, it works perfectly. It only happens for the same set of users.

For now, we have worked around it by setting a script to update the field. It will get us by but is strongly discouraged and unsupported by Cisco.


This Discussion