2940 problem

Unanswered Question
Jan 14th, 2008
User Badges:

Guru's, i encountered a very, very strange problem and i am looking for an explanation.


My customer is using a 2940 uplinked via fiber to a 3750 stack.

Clients are connected to the 2940 with 100 Mb/F, and a server is connected to the 3750 on 1000baseT.


A 10 MB file transfer from client to this server or vv takes 10 minutes. The same transfer to another server connected on the same 3750 takes seconds.

The server is a HP DL360 generation 5, Win2K3, sp2.


When we remove SP2 from the server, transfer takes seconds.

When we connect the client to a 2960 in the same network, (server on SP2) transfer takes seconds.


The problem seems to be in the combination HP with 2003/SP2 and a 2940.


We have tried several 2940 images. During a sniffing session the only strange thing i see is that the used window size is max; 65535.


Anyone ideas in this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nordick26 Mon, 01/14/2008 - 06:16
User Badges:

Hi,


is there any difference between int. speed & duplex configuration on 2940, 2960 and your server?

Once I have similar pb.

If you have 100/full on switch and auto on server, server will negotiate 100/half. If you have auto on switch and auto on server, they will both negotiate 100/full. If you have auto on switch and 100/full on server, switch will set up 100/half.


Maybe you already know all of this, but just wanted to avoid this pb.


Regards

Ivan

koksm Mon, 01/14/2008 - 06:26
User Badges:

The server is connected 1000/full (all servers are).


Clients are connected 100 full.


We checked this with the show interface command.

It's actually one of the first things i checked...

glen.grant Mon, 01/14/2008 - 06:59
User Badges:
  • Purple, 4500 points or more

Have you tried doing extended pings say 20000 packets from the 2940 and see if anything is being dropped ? Any errors on the client port or the uplink port , verify with the "show interface counters errors" command . You can check to see how busy the ports and switch fabric is with the show controllers utilization" command.

koksm Mon, 01/14/2008 - 07:05
User Badges:

Well, the thing is, the same client connected to the same 2940 but targeting another server on the same 3750 runs perfectly.


It is just the one server, when SP2 is installed.


But...the same client connected on a 2960, targeting this SP2 server again, no problem at all.



gkuchera Tue, 01/15/2008 - 12:19
User Badges:

It's entirely possible that SP2 broke/changed the settings on the ethernet adaptor on the server. veriify the settings and perhaps download the newest version of the driver from the manufacturer.


Usually when I see differences in timings like that I suspect dup/speed mismatches as well.


Also when ever you install service packs on windows systems you might want to consider defraging the OS drive as service packs in the past have had a tendency to fragment files.


my 2 cents

-gkuchera

koksm Wed, 01/16/2008 - 22:55
User Badges:

Agreed, but...

Of course latest NIC drivers installed.

And...why isn't there a problem with the same client connected to a 2960, connecting to the same SP2 server?

mr_ludvigsson Thu, 01/24/2008 - 05:52
User Badges:

I have the exact same problem. One server is extremely slow if you access it from a 2940 port, but if you're connected on a 2960G, it's super fast.


I'm not talking about he difference between 100Mbit/s and 1000Mbit/s here. It's way much more. Through a 2940 you get 50kbit/s and through a 29060G it's up to the computer and the SMB protocol to handle the speed.

Other servers work fine though.


This seems to be a case for TAC since it obviously a common problem for the 2940 switches.


/Magnus

koksm Thu, 01/24/2008 - 05:56
User Badges:

Phheeww, i thought i was going crazy!

Thnx for posting...let me know you find, i'll do the same...

Actions

This Discussion