Unanswered Question
Jan 14th, 2008

Hi NetPro Master.

anyone knows how to solve this problem ? i saw this problem for long time ago. but can not resolved :(

Jan 14 10:18:43.397: %C4K_EBM-4-HOSTFLAPPING: Host 00:0E:9B:53:44:1C in vlan 296 is flapping between port Fa2/2 and port


Information from CCO :


Error Message when the Host Address is a Source Address on Multiple Ports


The %C4K_EBM-4-HOSTFLAPPING:Host [mac-addr] in vlan [dec] is flapping between port [char] and port [char] error message appears.

This error message appears on the switch when the switch detects the specified host address as a source address on multiple ports.


The issue can occur due to Spanning Tree Protocol (STP) loops in the network that cause packet drops from the specific host. In addition to packet drops, STP loops lead to several other symptoms, which are listed here:

Loss of connectivity to, from, and through affected network regions.

High link utilization (often 100 percent).

High switch backplane utilization (compared to the baseline utilization).

Syslog messages that indicate packet looping in the network (for example, HSRP duplicate IP address messages).

Syslog messages that indicate constant address relearning or MAC address flapping messages.

An increase in the number of output drops on many interfaces.

Note: One or more of these symptoms independently can indicate different issues (or no issue at all). However, when you observe many of these symptoms at the same time, you must check whether a forwarding loop has developed in the network.


Enable spanning tree in order to prevent spanning tree loops. If you have disabled spanning tree, use the information in Spanning Tree Protocol Problems and Related Design Considerations to design your network without spanning tree loops.

so, what can i do with this ? i have checked the STP . looks ok but the logs still occur.

hope Master can guide me to resolve this.

your reply will be highly appreciated.




I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.3 (3 ratings)
dgahm Mon, 01/14/2008 - 22:27


What is connected to ports 2/1 and 2/2?

If you have a dual NIC server configured for load balancing you would experience this symptom. If this is the case you can configure an etherchannel on the switch side so both physical ports will be treated as a single logical port.


Please rate helpful posts.


ney25 Tue, 01/15/2008 - 01:18

Hi Dave,

Port 2/1 and 2/2 are the Wireless Access Point.

no load balancing being configured.




dgahm Tue, 01/15/2008 - 07:52


What is host 00:0E:9B:53:44:1C? Is it a wireless NIC? With access points it may be normal for MAC addresses to flap between the two. In which case you either just ignore the error messages or set your logging level higher.


ney25 Sat, 01/19/2008 - 03:24

Hi Dave,

sorry for the late reply, from your msg which means i just set the logging level higher will solved the issue ? and this was just an information only ? because, as i understand if this msg keep repeating it will causing high CPU utilization . kindly correctly me if you feel i am wrong.

thanks , and your reply will be highly appreciated.



glen.grant Sat, 01/19/2008 - 04:06

you are probably getting this because you have a user roaming between two different access points so his mac address keeps wandering between 2 different switch ports . The message should not cause high cpu , make sure console logging is turned off in the switch . It will fill the logs up though .

ney25 Sat, 01/19/2008 - 23:50

Hi Glen,

thanks for the information.



smothuku Mon, 01/21/2008 - 03:54

Hi ,

We are also facing same kind of problem as that of present post.

last week end we were planning to put the nortel FW's into production.

We were getting the following message on switches after terminating nortel FW's on the switches.

1w0d: %C4K_EBM-4-HOSTFLAPPING: Host 00:00:5E:00:01:0F in vlan 15 is flapping between port Gi3/1 and port Po5ping 19

1w0d: %C4K_EBM-4-HOSTFLAPPING: Host 00:00:00:00:FE:21 in vlan 15 is flapping between port Po5 and port Gi3/1

setup is as follows.

noter FW1(port4-sync)----(port 4)nortel FW2 .

| |

4507R sw1 (HSRP & Etherchannel)4507Rsw2

Vlan 15 is defined on both switches.

Vlan 31 , 32 ,33,51 and 52 are deifned on nortel FW.

Valn 15 port is access port and remaining are trunk ports.

Both FW's are in sync i.e port 4 is connected back to back.

I've noticed that 1. When ether-channel is up , we are getting the hostflapping messages and we are not able to ping to FW2 from any any of the Switches.Not even from FW1.

2.If i shut down the port-channel , then FW1 is able to reach from sw1 and fw2 from sw2.

We were not getting the messages.

Whenever port channel is coming into picture at that time we are facing this problem.

Any help would be appreciated.




This Discussion