Configuring HSRP w/secondary ip

Unanswered Question
Jan 15th, 2008

We currently have a 3845 configured

with a secondary interface on the ge

nterface GigabitEthernet0/1

description connection to lan

ip address 192.168.2.222 255.255.255.0 secondary

ip address 192.168.2.236 255.255.255.0

My question is..how would i configure hsrp to include these two ip's and

2 different ip's on the new router..

for a total of 4 ip's in one group

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ankbhasi Tue, 01/15/2008 - 07:04

Hi Friend,

Is there any specific reason you have configured same subnet ip address as primary and secondary and then you want HSRP to run for both the ip address?

You can configure hsrp for primary as well as secondary ip address using command

standby ip

standby ip secondary

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00801d2d21.html

HTH

Ankur

*Pls rate all helpfull post

nygenxny123 Tue, 01/15/2008 - 13:54

Hello-I am new here and just found out the config to be that way..thx for your help!

cisco24x7 Tue, 01/15/2008 - 17:36

Something like this will work:

C2621#sh run int f1/0

Building configuration...

Current configuration : 1315 bytes

!

interface FastEthernet1/0

description DMZ Network

ip address 192.168.1.194 255.255.255.128 secondary

ip address 192.168.0.130 255.255.255.128 secondary

ip address 192.168.155.242 255.255.255.248 secondary

ip address 10.100.197.2 255.255.255.240 secondary

ip address 172.25.2.242 255.255.255.240 secondary

ip address 192.168.0.2 255.255.255.128

ip accounting output-packets

ip accounting mac-address input

ip accounting mac-address output

ip nat inside

ip flow ingress

ip route-cache flow

speed 100

full-duplex

standby 1 ip 192.168.0.1

standby 1 priority 105

standby 1 preempt

standby 1 authentication hsrp_1

standby 1 name HSRP_DMZ_1

standby 2 ip 192.168.1.193

standby 2 priority 105

standby 2 preempt

standby 2 authentication hsrp_2

standby 2 name HSRP_DMZ_2

standby 3 ip 192.168.0.129

standby 3 priority 105

standby 3 preempt

standby 3 authentication hsrp_3

standby 3 name HSRP_DMZ_3

standby 4 ip 192.168.155.241

standby 4 priority 105

standby 4 preempt

standby 4 authentication hsrp_4

standby 4 name HSRP_DMZ4

standby 5 ip 10.100.197.1

standby 5 priority 105

standby 5 preempt

standby 5 authentication hsrp_5

standby 5 name HSRP_DMZ_5

standby 6 ip 172.25.2.241

standby 6 priority 105

standby 6 preempt

standby 6 authentication hsrp_6

standby 6 name HSRP_DMZ_6

end

C2621#

CCIE Security

Actions

This Discussion