ICM historical reports not working

Unanswered Question
Jan 15th, 2008

Hello,

We had a "network failure" according to the IPCC systems. Since then, there is no data for Historical reports (since the failure, older reports still pull up). Real-time reports also still show up, so I am assuming there is some kind of database replication problem. We have 2 redundant routers, loggers, and AW/HDS. I am not seeing any out of the ordinary errors on any of these. I have tried to cycle the services in the ICM service control on the router and aw/hds. Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lpezj Tue, 01/15/2008 - 08:26

Hi,

The Distributor is connected to only one Logger to get historical data. If you have only one distributor and the primary Logger is down you will not be able to get historical reporting.

After you recover the Logger, you will have all the historical statistics in the next 30 minutes.

Hope this helps,

Juan Luis

kre8or2007 Tue, 01/15/2008 - 12:09

Hello,

That's the weird thing; the crash happened last Thursday and we have no historical data since that time. All IPCC servers are back up and operational, and I am not getting any error messages in the event log. Real-time reports are working and so is historical data from before the crash. It sounds like for some reason the AW DB isn't updating from the Logger, and the redundant AW isn't updating from the primary AW?

jeff.marshall Tue, 01/15/2008 - 13:57

The Replication process is the process that connects the HDS to the Logger and collects the historical data. What does it show on the HDS as well as the logger that it is pointed to? What happenes if you cycle the services on the HDS? Does that change the REPL data?

/Jeff

kre8or2007 Tue, 01/15/2008 - 14:03

Hi,

I have already cycled the HDS and router processes. After looking around, I just figured out that the Loggers aren't even logging data since the crash. There are no errors or processes down. Both replication processes are started (2 AW's), but apparently it doesn't matter since the logger isn't putting data into the db. Real-time reports come back with information, but I think that comes from the Router. I think I will be rebooting the loggers after hours unless I can come up with something else. I appreciate the help.

Jim

bill.king Wed, 01/23/2008 - 07:26

I ran into a somewhat similar problem before. You might want to try, when you reboot your Logger, to take down just the one side. We had an issue with the Transaction Key being mismatched, and had the problems you described. Until we had the final solution, if we ran on just the one Logger, we were OK. Hope this helps.

Actions

This Discussion