vrf and normal IP redistribution

Unanswered Question
Jan 16th, 2008

I have a network in which the voice(IP Phones) run through vrf. all other networks are carring IP traffic.

Now i have to add IP phone in a network that runs IP traffic. Is it possible for me to redistribute the new IP phone, which carries normal IP packet, to the orginal vrf voice network without running vrf in the new network. i have ospf running in both ip and vrf network, each running on a seperete proccess ID. Is there possible that i redistribute between them .

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
bjornarsb Wed, 01/16/2008 - 06:11


As far as I know, getting access to the global routing table use the global keyword:

ip route vrf customer1 global

You also need to ensure that packets coming back from the router reach its destination:

ip route



swaroop.potdar Wed, 01/16/2008 - 11:34

Looks like you are running vrf lite in the network.

At whatever point you want to carry out this redistribution, since you cannot redistrbute directly between ospf vrf instances,

it would be a good idea to run standalone bgp and do a import export with route targets using route-maps to slectively leak

the routes between the vrf's. Again this method would not need you to enable MPLS label forwarding and also achieve the

routing you need between the vrf's in a controlled manner.



rajesh1331 Fri, 01/18/2008 - 01:58


It works fine for me one way..

ie , i can get the VRF route in normal IP table but not able to get route for the normal IP in vrf table.

Iam not sure if i done the redistribution correctly . Is it something to do with that...



mheusing Fri, 01/18/2008 - 04:48


Try a static route pointing to the VRF interface and redistribute it in your IGP. F.e.:

ip vrf voip

rd 65000:1

interface Serial0/0

ip vrf for voip

ip address

interface Ethernet1/0

ip address

router ospf 10

redistribute static subnets

network area 0

ip route vrf voip global

ip route Serial0/0

If you specify a next hop by only the IP address in the last static, the next hop will be resolved through the global routing table and packets will not be sent into the VRF.

Hope this helps! please use the rating system.

Regards, Martin

rajesh1331 Mon, 01/21/2008 - 23:13

Hi martin..

your suggssions were helpful. I tried it and got while testing I got the route for vrf in my normal routing table but still not getting the IP route in vrf routing table. I doubt if it has got something to do with my redistribution.

Anyway iam sending you the scenario once again as an attachment along with a figure Hope this helps you in understanding the problem. It would be great if I could get a solution ..

mheusing Tue, 01/22/2008 - 01:16


You do not have static routes in your configs given in the attached document. So the suggestion is:

router ospf 50 vrf voice


redistribute bgp 1 metric 100 subnets

redistribute static subnets

network area 0

router bgp 1

address-family ipv4 vrf voice

redistribute ospf 50 metric 100 match internal external 1 external 2

! otherwise no ospf external routes will be redistributed. I am not sure, if you omitted them by design or just forgot it. In any case check, if this results in the desired connectivity or not. It might not be required in your environment.

redistribute static

! redistributes the static vrf route to other PE routers.

no auto-summary

no synchronization


ip route vrf voice global

! the next hop is in the global routing table

ip route Serial0/0

! the interface belongs to the vrf voice

That should implement packet leaking and redistribute the static routes in the VRF and global routing table. Off cource you need to adjust the IP addresses and interfaces to your environment.

Hope this helps! Please use the rating system.

Regards, Martin

rajesh1331 Tue, 01/22/2008 - 05:16

Hi Martin..

I think Iam almost there.

Iam stuck up with that vrf static routing. which network is actually the in

ip route vrf voice global

are you referring to the customer network. thas where iam getting confused

thanks and regards


mheusing Wed, 01/23/2008 - 06:19

Hi Rajesh,

The 10.2/16 in my example is found in the global routing table, namely the next hop has a global routing table entry for that network.

The VRF routing table needs an entry for this network to perform IP lookups and forward packets towards 10.2/16. Hence there is a static route generated in the VRF to allow this.

Hope this clarifies! Please use the rating system.

Regards, Martin

rajesh1331 Wed, 01/23/2008 - 06:40

Hi martin..

Thanks for you help.. Will surely get back to you after I try it.. hope all goes fine.



rajesh1331 Mon, 01/28/2008 - 20:55

Hi Martin,

I got that point, but still not able to get the complete leaking done.

I have created subinterfaces for splitting the vrf and voice network

The vrf network comes in GE0/1.50 . The network is

and the IP network is in GE0/1.6 with network

My Ip phone which has to be in IP network is (n/w is

and my call manager servers are and

Could you please tell me how the static routing should be given for

route leaking with my IP addresses as an example.

Interface configuration in router at present:

interface GigabitEthernet0/1.6

description **Link_to_L3_Port_Gig 4/25_Backbone Link for IP traffic**

encapsulation dot1Q 6

ip address

service-policy input policy-in


interface GigabitEthernet0/1.50

description **Link_to_L3_Port_Gig 4/25 for VOICE VRF Traffic**

encapsulation dot1Q 50

ip vrf forwarding voice

ip address

Thanks and regards



This Discussion