dlsw using port channel

Answered Question
Jan 16th, 2008

I have 2 dlsw router at head quater office, named dlswA and dlswB.

From branches router, dlswA is a primary peer and dlswB is a backup peer.

Both dlswA and B have 2 fast ethernet interfaces.

The current configuration of dlswA and dlswB are 1 port as IP port and other port as sna/bridge port.

With this configuration the problem is when SNA port at dlswA problem, then dlsw circuit will have the problem, because dlsw peer from branches still connected to dlswA.

if I configure 2 fast ethernet port become a port channel. And configure IP and bridge group at port channel interface (IP and SNA at the same interfaces), so when the port channel is down, then branches will connect to dlswB as a backup peer

Are the port channel configuration will solve the problem ? How about the stability of this configuration?

Correct Answer by mbinzer about 9 years 1 month ago

Hi,

i was discussing with some people here and i guess if it works for netbios it will work for sna aswell. At the end it is not different from

the case where the ip traffic and the bridged

traffic come and go over the same interface.

We have customers doing that for a long time.

Your solution with the port channel should work fine for the case where you use dlsw with bridge groups.

And just to be sure that my understanding is correct, in your case the two ports of the port channel on the switch are in the same vlan. I guess otherwise the channel would not form anyway.

thanks...

Matthias

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
mbinzer Wed, 01/16/2008 - 22:35

Hi,

i dont think that a port channel will help you in this scenario.

1. as far as my understanding goes a port channel does not go down if at least one member of the channel is still up. So you would have to go both channel members go down to get the port channel down and trigger something on the other router.

2. I dont think that mixing ip routing and bridging in a port channel is really going to work. for sure no one is testing this scenario.

if i understand your description correct you have a classic topology with a branch peering to two head end routers.

The second peer is defined as a backup peer of the first one. However a dlsw backup peer only backs up the tcp portion of the peer.

If you want to have full backup of the path you would have to use two permanent peers from the branch. One to each host end router.

However that depends a bit on how the topology on the host end looks like. I.e. since you say fast ethernet ports, are both head end routers on a common ethernet? Or do they go to two different hosts using the same mac address on different ethernet lans?

Can you give some more details about your setup?

thanks...

Matthias

aris.thio Wed, 01/16/2008 - 23:20

Thank Matthias for your reply.

Both of head end routers are on the same vlan and the host is using same mac address.

As far as i know if from branch have 2 active peer with cost setup, there will loops posibility because both head end routers are using ethernet with same vlan and same host mac address.

I test the port channel within my LAB using netbios, seem works as expected. when single port at port channel down, branch circuit still remain at dlswA router, when all port channel member down, the branch peering move to dlswB.

Here are the config:

hostname dlswA

!

dlsw local-peer peer-id 192.168.255.1 promiscuous

dlsw bridge-group 1

!

interface Port-channel10

ip address 192.168.255.1 255.255.255.248

bridge-group 1

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

channel-group 10

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

channel-group 10

!

end

hostname dlswB

!

dlsw local-peer peer-id 192.168.255.10 promiscuous

dlsw bridge-group 1

!

interface Port-channel11

ip address 192.168.255.10 255.255.255.248

bridge-group 1

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

channel-group 11

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

channel-group 11

!

end

Hostname Branch

dlsw local-peer peer-id 172.16.0.1

dlsw remote-peer 0 tcp 192.168.255.1

dlsw remote-peer 0 tcp 192.168.255.10 backup-peer 192.168.255.1 linger 0

dlsw bridge-group 1

!

!

interface Loopback0

ip address 172.16.0.1 255.255.255.255

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

bridge-group 1

!

But I'm not sure this scenario will work for sna application like ATM machine, and SNA SAA gateway.

Please kindly advised, Is there any alternatif ?

Correct Answer
mbinzer Thu, 01/17/2008 - 02:51

Hi,

i was discussing with some people here and i guess if it works for netbios it will work for sna aswell. At the end it is not different from

the case where the ip traffic and the bridged

traffic come and go over the same interface.

We have customers doing that for a long time.

Your solution with the port channel should work fine for the case where you use dlsw with bridge groups.

And just to be sure that my understanding is correct, in your case the two ports of the port channel on the switch are in the same vlan. I guess otherwise the channel would not form anyway.

thanks...

Matthias

Actions

This Discussion