Extension Mobility XML Service

Unanswered Question
Jan 16th, 2008

Hi,

I am trying to use EM API and am a bit confused. I know that what I need is send an XML file over HTTP to the URL:

http://192.168.0.150/emapp/EMAppServlet

I also know that I need to certify my XML with an AppID and a certificate password.

My question is what is exactly that application id and password and where can I configure them?

My test was as follows:

------------------------

<request>

<appInfo>

<appID>EMService</appID>

<appCertificate>password</appCertificate> </appInfo>

<login>

<deviceName>SEP0025C43076AA</deviceName>

<userID>303</userID>

</login>

</request>

------------------------

But when I read the response in my .NET application I get the following:

------------------------

<CiscoIPPhoneText>

<Title>Login response</Title>

<Text>Login Unsuccessful</Text>

<Prompt>Error: [100]</Prompt>

<SoftKeyItem>

<Name>Exit</Name>

<URL>SoftKey:Exit</URL>

<Position>1</Position>

</SoftKeyItem>

</CiscoIPPhoneText>

-------------------------------

What am I doing wrong?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Mike-1985 Wed, 01/16/2008 - 23:52

The appID is the userID of the user you want to login. And the appCertificate is the user's password! (not it's pincode you normaly use when loggin in onto a phone itself!)

edit.

the userID is the same as appID

walidazab Thu, 01/17/2008 - 01:14

Hi,

Thanks for your answer. I followed your directions but the error is the same!

My XML Message is:

------------------

303

1234

SEP00115C4076AE

303

------------------

And the error is:

--------------------------------

Login response

Login Unsuccessful

Error: [100]

Exit

SoftKey:Exit

1

--------------------------------

I hope there is an explanation to that?

Thanks

Mike-1985 Thu, 01/17/2008 - 01:36

Are you able to login manualy on the phone using the same credentials? I don't think the userID is correct. This usually is NOT numeric (altough the word ID might be a bit confusing).

What username do you use when you manualy login the phone? This is the userID the EM service wants

edit:

Witch version of Call Manager do you use?

walidazab Thu, 01/17/2008 - 02:05

Well, yes I am able to log on manually. I just did now.

Yes I also use the same user ID when I log on to the service manually using the phone set. I also use the same user when logging onto CCMuser page.

I am using CCM version 3.3.4.

Mike-1985 Thu, 01/17/2008 - 07:19

hmmm...

I'm not sure if the CCM 3.3.4 has an Extension Mobility API. I have been working with CCM 4, CCM5 and CCM6 they have the EM API so no problem at all.

I tried to find out anything about the EM API for CCM versions below 4.1, but could not find anything. Have a look at this page: http://www.ccnp.biz/en/US/products/sw/voicesw/ps556/products_programming_reference_guides_list.html

Are you sure CCM 3.3.4 has an EM API?

schemberg Sun, 01/27/2008 - 23:18

Hi,

yes CM 3.3(4) has an EM API and as far as I know it didn't change until 6.x.

May be your problem is related to "Authentication Proxy Rights"? You have to check this right at the user device profile page. With this right one user can login any other user to any other phone.

Regards

Axel

siddharthsukhija Thu, 05/22/2008 - 05:51

Hi,

I also faced a similar problem, what i did was that in the first two fields where appid and password was required i used CCMAdministrator and its password. The device name remains the device you want to login and userid is the call manager user id who has to login onto the system. I am not sure if CCMAdministrator should be used here but it certainly worked in my case.

Thanks,

Sid

Actions

This Discussion