CUCM6BE BAT Tool

Unanswered Question
Jan 16th, 2008

Hi there,

I am installing a CUCM6 business edition with unity connection 2.

I am having problems with associating the end user with a primary extension during the bulk admin stage using the BAT tool.

In the bulk spreadsheet under the user tab I use the “Primary Extension” and under the user template I have checked the “Default Telephone Number to Primary Extension” box.

Under user in CM when I select the primary extension combo box, the primary extension is not there, it is not added at the bulk admin stage and as a result I have to manually add it. Having to put the Primary extension in is the only way that Unity will import the user. In the CUCM6BE there is no way to add a subscriber manually.

Any ideas or anyone know a way round this

cheers

Paul

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

I am not sure if this will fix your problem, but one of the things I noticed about this version of BAT is that you must enter the information exactly how it is shown in the admin pages.

For example to associate a device to a user, you must put the MAC address prefixed by SEP (SEP00124ab28412) You must also associate a device before you can set the primary extension. When you set the primary extension you must again use the format exactly how it is in the user pages. "Extension in Partions" or "115 in Inside-CSS".

bigcappa1 Tue, 01/22/2008 - 02:06

Braden,

Thanks for the advise, doing another install using CUCM6BE next week, so will try out your methodoligy and let you know how it goes

Regards

Paul

bigjamdonut Wed, 02/20/2008 - 08:52

Hi there

Just to add to this post i am having the same problem but with with CallManager 6.1. I tried the solution suggested here but get the error message "Directory number may only contain numbers and char '+''!''X'..."

Dose anyone else have any other suggestions?

Cheers

Alexis

soupseven Mon, 02/25/2008 - 23:33

Do not modify it from the Excel file. Do it from the txt file. It is working.

bigjamdonut Wed, 02/27/2008 - 02:29

Just to say that i tried that today and it works!

Thanks for the help :)

Alexis

kgroves42 Thu, 03/20/2008 - 12:54

How did you get this to work?

I have all my users added

all of them have a controlled device with SEP...

I can manually go into each user and change the primary extension, but that would take forever with well over 100 users on this server. (of course I am spending way to much time trying to figure this out, it might have been quicker to do that)

I have run "update users" a bunch of times, my text files seem good. It always runs without any errors.

In my user template, the check box is checked to Use Telephone number as Primary extension.

But nothing seems to work. am I missing something easy?

Thanks

Ken

Tommer Catlin Thu, 03/20/2008 - 16:05

I found a bug in the Export tool to CSV. I imported it into Excel to edit the data. The field names at the top excel, the exported added a space after the field name. You could not see it and when you tried to import it threw errors. I finally found it, but it was a mess. Thought I was doing something wrong in CSV and it was something the export did.

bigjamdonut Fri, 03/28/2008 - 04:18

hi Ken

"In my user template, the check box is checked to Use Telephone number as Primary extension." I don't think this has any effect on the import. I would say its a bug.

Like soupseven suggested when you export from the excel spread sheet and create a cvs file ready to be uploaded into CM, before uploading the .cvs file open it and place the exact naming convention "123-OWNET" for the primary extention

cheers

A

Actions

This Discussion