cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1139
Views
0
Helpful
5
Replies

RIP Advertise only (no Learn)

jwilde
Level 1
Level 1

Lets say I have a 48 port Layer 3 switch and I only want to advertise out of one interface (with the ability to add interfaces later; one at a time) and not receive any advertising. What is the easiest way to accomplish this task without advertising out all of the other interfaces. I will eventually be adding other interfaces as we bring on devices connected to that interface, but I do not want it to broadcast out every interface. I am guessing I will need to add a default to the router rip statement of some sore. I also know that I could suppress advertising by doing a default passive interface, but I do not want them to receive rip updates. These legs are the only thing that runs rip on the network and is intended for FTTH NIDS. If there is a document that would help, I would appreciate that too.

This is a generic sample of what I am doing right now:

version 2

redistribute ospf <process number> metric 2 route-map KENZ

network 10.0.0.0

distribute-list 15 out

distribute-list 16 in

no auto-summary

access-list 15 permit 10.0.1.0 0.0.0.255

access-list 15 permit 10.0.2.0 0.0.0.255

access-list 15 deny any

access-list 16 deny any

route-map KENZ permit 10

match ip address 15

Ideally, I would advertise through specific vlan(s) SVI. Thank You in advance.

5 Replies 5

froggy3132000
Level 3
Level 3

The easiest way is what works for you. If its working I wouldn't touch it.

with the code i posted, it was advertising out all of the interfaces. I think cause they are in the 10.x cloud. That is why I asked. I don't think they are listening though.

Kevin Dorrell
Level 10
Level 10

You are right that your config will advertise 10.0.1.0 and 10.0.2.0 out all the interfaces on 10.x.x.x, but will listen to nothing.

The distribute lists can be made to operate VLAN by VLAN, (or layer-3 interface by layer-3 interface, if you are using them) oe globally as you have them at the moment.

Are all your interfaces in the same broadcast domain, or are they split up into different VLANs?

Please could you tell us a bit more about the layer-3 configuration of your switch, and maybe attach a show run. Also, what switch is it?

Kevin Dorrell

Luxembourg

The interfaces are actually trunks. There are a couple of them that are actually routed ports however too. The interfaces are set up in different broadcast domains and are on seperate vlans. The vlans would be perfect and was what i was looking for. This is a 3750 that has 802.1q vlans to DSLAMS. There are usually 4 VLANS:

1) Internet

2) Voice

3) Video

4) Management

I only want to send out rip advertisements out the Management VLANS. Here is the exact port configuration/ interface I am talking about:

nterface GigabitEthernet1/0/6

description to-SAI-6999-4-BAS-BX

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 15,131,225,324

switchport mode trunk

The vlan 324 is where I want rip advertised. The other ones i do not want any rip at all.

interface Vlan324

description VoIP-MGCP-FTTH

ip address 10.101.31.1 255.255.255.0

ip helper-address 10.100.254.25

no ip proxy-arp

I have tried doing rip like this:

router rip

version 2

redistribute ospf 3000 metric 2 route-map KENZ

network 10.0.0.0

distribute-list 15 out Vlan324

distribute-list 16 out

distribute-list 16 in

no auto-summary

This seemed to break everything which kind of makes sense. I mirrored g1/0/6 and didn't see rip at all after that. I didn't see it out the other interfaced either though :).

Basically, I want to advertise only on specific VLANS. I can post run-config if that would help, but I think this helps.

All 10.x.x.x will be advertised.

You can do a passive-interface default under the RIP process and then a no passive-interface Vlan324.

These commands will disable the interfaces for RIP but they will still be advertised.

If you don't want them advertised, I suggest changing the IP address scheme on the management interfaces to 192.168.x.x for instance.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card