no green LED on SFP fiber trunk

Unanswered Question
Jan 16th, 2008
User Badges:

I'm trying to configure a fiber trunk between a Catalyst 3560 switch (Gi0/1) and Catalyst 3750 switch (Gi2/0/50). The SFP modules (GLC-SX-MM) are seated and the cables appear connected fine, but I get no green LED lights on either switch. Port settings for both are: status enabled, duplex: auto, speed: auto, portfast: disabled, flow ctrl (receive): off. I do have fiber trunks on other SFPs working fine. What troubleshooting steps should I take to bring the fiber trunk up to "Duplex Full, speed: 1000 ?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Hieu Cao Wed, 01/16/2008 - 17:45
User Badges:

Have you configured those ports as trunk ports yet? Those ports are not going green until the trunk link is established.


switchport trunk encapsulation isl

switchport mode trunk


If you've already configured those ports as trunk ports and it still doesn't work, perhaps you might want to try different ports or SFP modules and fiber cable just in case the hardware is actually bad.


hieu

sewing@dcyf.org Thu, 01/17/2008 - 11:53
User Badges:

Yes, the trunks are configured for dot1q encapsulation. I solved the problem by inverting the LC ends of the fiber patch cables. It needed to be TX --> RX, instead of TX-->TX. The green LED came up immediately after making this change.

unfirenothomas Wed, 01/16/2008 - 19:27
User Badges:

If you do a


sh int status


does the SFP module show up correctly? If the gbic is bad, it would not show up at all or state "unknown", etc.


interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk


interface GigabitEthernet2/0/50

switchport trunk encapsulation dot1q

switchport mode trunk


Usually auto duplex and speed work best for stacking.


Pavel Bykov Thu, 01/17/2008 - 01:15
User Badges:
  • Silver, 250 points or more

Maybe you have a miswiring problem. Although this should be a problem with LC cables, with SX/MM you can check the cables visually:

Unplug the cable from the port, and look from very close inside the connector as if the cable was a tube - locate which connector is lit with red light (very dim, you might need to put a hand around to cover the ambient light from the room fixtures). Then look closely inside the SFP connector, and again one of the connectors will have to be lit with red light.


Cable connector with light has to go into port with no light, and vice versa, cable with no light has to go into connector with light.



Also, try setting flowcontrol to on - helped me connecting the routers with switches. This is probably not going to be a problem, but it won't hurt to try.


Try manual speeds as well - speed 1000; duplex full



Regards,

Pavel

Actions

This Discussion