CUPS 6 Users not updating

Unanswered Question
Jan 17th, 2008

Hi we have cucm 6, ldap sync and CUPS 6 server. users appear in CUCM from AD but when we assign capablities for them for CUPS they do not appear in the CUPS server. if we reboot the CUPS server the users appear. Troubleshooting guide gives all clear. Any advise appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Tommer Catlin Thu, 01/17/2008 - 09:04

Do you mean, when you enable them for CUPC in CUCM, they do not appear on the CUPS server? If that is that case you have an AXL problem. AXL is pulling this information for CUCM to CUPS. I would probably delete the AXL information for CUPS, re-input it and see what happens. Also, check your RTMT and see if the logs are showing any errors (application, system, etc)

jeff.singh_2 Thu, 01/17/2008 - 15:00


yes when I enable for cupc in cucm(capabilties assignment) they do not appear in CUPS. Only when I either reboot the CUPS server or manually just restart the Cisco UP sync agent service then the users appear in CUPS server.

The AXL user, its password has been reset on both CUCM and CUPS, it also has standard AXL API access and has control of all devices. Still same problem.

Tommer Catlin Thu, 01/17/2008 - 15:14

I think you still need to setup up a trace, but check out this doc.

There is clearly an error in the sync agent on why it is not updating. I have also seen a problem or remember ready a note that if the password had special characters in the AXL account, it will not work. So try and easy password for the AXL account. (if you have not already)

matt22coll Mon, 04/13/2009 - 14:49

Hi Jeff,

Do you have any Firewalls in the way, We had the same issue caused by our ASA's, CUCM uses one port to do a complete sync after reboot or restart then another port to carry out all updates after that, If you do I'll dig out the port number you need to grant access to tomorrow when at work.

Hope this helps.


htluo Mon, 04/13/2009 - 16:12

This is a typical "Change Notification Issue" (CN).

"Change Notification" is a mechanism to trigger update between different components.

When you update users on CUCM, CUCM should send CN to CUPS via IPSEC. CUPS, upon receiving CN, would trigger SyncAgent to pull the update.

If you got CN issue, notification won't be sent from CUCM to CUPS. Thus CUPS won't trigger the SyncAgent. The work around is to restart SyncAgent on CUPS manually.

Usually, CN issue was caused by one (or more) of the following:

1) Secret password on CUCM and CUPS mismatched.

2) Hostname was changed on CUCM or CUPS. However, some of the configuration files were not updated (bug).

We'll need Cluster Manager logs from CUCM and CUPS to verify. Sync Agent log from CUPS would also help.




This Discussion