SFP Link performance

Answered Question
Jan 17th, 2008
User Badges:

Hi everyone,

I have a problem with performance over SFP links. In core I have two 6509 (12.2(18)SXD7)and WS-X6748. In access-layer I have many 3560. I have connected a 3560 and a 6509 via SFP and Trunk configured without redundancy (one link). There are no Error on interfaces. But the performance is very bad. I have connected the same devices via cupper with the same trunk-config and the performance is good.

The interface-Config:


udld port aggressive on fibre

switchport

switchport trunk encap dot1q

switchport trunk native vlan xx

switchport trunk allowed vlan x,x,x,x

switchport mode trunk


I have changed the cable, SFP-GBICS, interfaces but without success.

What can I do, can you help me?

Tank's Rene

Correct Answer by plumbis000 about 9 years 3 months ago

If you've ruled out layer 1, I'd check to make sure the switch itself isn't the problem. Look into your CPU and memory usage to see if there is anything suspicious there ("show proc cpu history", "show proc cpu sorted", "show proc mem" and "show mem summary")


Also, although there are no errors, are you seeing a lot of giants or runts on either side of the link?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
plumbis000 Thu, 01/17/2008 - 07:03
User Badges:

If you've ruled out layer 1, I'd check to make sure the switch itself isn't the problem. Look into your CPU and memory usage to see if there is anything suspicious there ("show proc cpu history", "show proc cpu sorted", "show proc mem" and "show mem summary")


Also, although there are no errors, are you seeing a lot of giants or runts on either side of the link?

glen.grant Thu, 01/17/2008 - 07:33
User Badges:
  • Purple, 4500 points or more

How long is the fiber link and what kind of sfp are you using SX , LX/LH etc... Also what kind of fiber are you using?

renekrueger Fri, 01/18/2008 - 04:20
User Badges:

Hi, thanks for your help.

I have found the problem.

There was qos configured globally. (mls qos)

But I don't understand why is it so.

QoS on the interfaces is disabled, QoS maps are default. Why is the performance over fiber bad when QoS is globally enabled?????

Actions

This Discussion