Secure SRST on a Cisco2821

Unanswered Question
Jan 17th, 2008

Good day to all!

I'm trying to find out if Secure SRST is supported on the Cisco 2821 router. I know that normal SRST is supported and that Secure SRST requires a k9 IOS (that I have in place) however the commands are unrecognised when I type them in. Yes, that usually means that the feature is not supported on that device but I want to be able to confirm that officially with Cisco using some kind of documentation. I've trawled through the huge world of Cisco documentation but most of the information I'm finding is ambiguous or contradictory - can anyone give me a definitive yes or no please?!

Thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Markus Schneider Thu, 01/17/2008 - 10:50

I can find no reason why it shouldn't work. What is the exact image that you're running?

chrisgillies Fri, 01/18/2008 - 01:11

I also can find no reason why it shouldn't work - alternatively I cannot find confirmation that it WILL work!

Using c2800nm-advipservicesk9-mz.124-15.T1.bin

on the router in question, which according to the Cisco Feature Navigator ( DOES support SRST, however if you search by the Secure SRST feature then look at the platforms available, it only gives you the option of 7200-NPE-G2, 7201, 7600-CMM, 815, CAT6000-CMM and IAD2801 platforms, which suggests that while the feature is built into the IOS, it will only work on certain platforms.

So on the one hand I have information stating that the IOS supports Secure SRST, but on the other hand it hints that only certain platforms can actually use that feature.

Paolo Bevilacqua Fri, 01/18/2008 - 03:09


Like anything else, the feature navigator can and sometime is wrong. In this case, the reference to 815 is clearly showing the error, as such model doesn't support voice at all.

Ideally, the corrections should be made by people within cisco, however you can use the feedback form to let cisco know of any inaccuracies. Sometime, this results in corrections being made.

chrisgillies Fri, 01/18/2008 - 03:19

I've had a customer answer my question for me - they've been able to get Secure SRST working on the 2821 using the IOS images that the feature tool recommends, so it's partially right!


This Discussion