Static NAT entries - adding static routes by default

Unanswered Question
Jan 17th, 2008

Hi, Hi,

I have a 2600 running


Some static nat entries are configured, and I am seeing static routing entries being entered into the routing table without any configuration to do so. I don't see anything in the config that would account for this, and this isn't standard IOS behavior...

Am I missing something, or does this look like an IOS rev issue?

There's no interface on the router that is in either address space, so there should be no weird issues like that...

FastEthernet0/0 is administratively down, line protocol is down

Serial0/0 is up, line protocol is up

Internet address is

Serial0/1 is up, line protocol is up

Internet address is

Loopback0 is up, line protocol is up

Internet address is

Loopback2 is up, line protocol is up

I don't want these static routes in my table as they are altering some dynamic routing.


Lisa G

snippets of the config:

ip nat outside source static

snippet from the routing table:

S [1/0] via

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Jon Marshall Fri, 01/18/2008 - 00:51


There is an option with the "ip nat outside .." command called "add-route". If you add this at the end of the line it will add a static route into the routing table for the NAT translation as is happening with you.

Obviously you haven't got this in your config but i wonder if it is adding it anyway by default. Perhaps an IOS issue as you say.

I have tested on a 2600 and don't get this problem but i haven't tried with your IOS. If i get a chance i'll try it out.


lgontarsk Fri, 01/18/2008 - 09:52

Thanks Jon for that info. i didn't know that there was an add on to the nat outisde command for adding static routes. I think this is obviously a bug so I will check out bug toolkit or open a case to get the fixed rev.

Thanks for your help!

Lisa G


This Discussion