Problem With Attendant Console using CUCM 6.1.1

Unanswered Question
Jan 17th, 2008


I've set up Attendant Console. Configured the ac user as an application user, associated him with the pilot point (which is registered) and gave him the right CTI enabled and CTI Allow Control of All Devices. For the ACDeviceAuthenticationUser I associated this user with my receptionists' phone and gave him the same rights.

Configured the hunting and the attendant console user.

When I call my Pilot point I'm in the queue so so far all functions well.

However, when I try to login using the Attendant Console client, I can select my phone, the lines of that phone are recognized, but my call control does not come up...

Can anyone help me with this issue?

I've restarted both CCM-service as the AC-service, but no result.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (7 ratings)
angelique.devos Fri, 01/18/2008 - 05:45

Hi Rob,

Already read that topic before I posted this thread :-)

I've found the problem however. In you Cisco Communications Manager Attendant Console Service Parameters, there is an ACDeviceAuthenticationUser. As this is a required field, I assumed that I needed to create this account as an Application User... Wrong idea.. After deleting this Application user everything functions.



rob.huffman Fri, 01/18/2008 - 06:05

Hi Angelique,

Sorry for that :) Thanks for posting back with your solution to this problem. 5 points for helping others who may encounter this issue going forward.

Take care,


akascarface Thu, 02/07/2008 - 11:31

I'm having the same issue. TAC is no help either..imagine that. I did read this blurb:

You can enable Cisco Unified Communications Manager Attendant Console devices without associating each of the them with the ac application user by enabling the super provider feature.

To do this, associate (add) the ac application user with (to) the Standard CTI Allow Control of All Devices user group. After you enable the super provider feature, you must not associate any devices with the Cisco Unified Communications Manager Attendant Console ac application user.

Caution : System instability can occur if you associate devices to the Cisco Unified Communications Manager Attendant Console application user.

During an upgrade from Cisco Unified CallManager Release 4.x, the system automatically converts the attendant console application user to a superprovider user and disassociates the devices that were previously associated to the application user. after the upgrade from 4.X this super provider role is associate to the "ac" user and and it disasociates the previously associated devices ie)phones and pilot points. It further warns agains re-assoicating them. I did fall down the same trap as everyone else here about the ACDeviceAuthenticationUser. I knew that had to be optional. The first words of the documentation were If you "want" to enable security...etc.

I'm not sugesting this is a fix.. I still can't get it working. This serves just as a warning for the next guy who reads this stuff. Anyway does anyone have a solution yet? Because:

1) Deleting the optional ACDeviceAuthenticationUser from the Aplication Users

2) Associating and dis-assocating the phones and pilot points

didnt fix anything for me. My ACs are still broken.

Thanks guys

akascarface Thu, 02/07/2008 - 12:26

OK here's an update. I got desprate so I compltely blew away all AC config and started over.


I rebuilt the entire configuration with the "ac" account last. I gave it the account the Standard CTI Enabled and Standard Call Park Monitor Permision without giving it the Standard CTI Allow Control of All Devices permission. Then I assoicated the the phone and pilot point. Restarted CTI Manager and CTI AC Service and same better off.

2) Then I un-assoicated the phone and pilot point and added the Standard CTI Allow Control of All Devices, Restarted CTI Manager and CTI AC Service and it came up.

Now the question is: Did I truly have to be that agressive and rebuild the entire config? Or did I simply have to remove the Standard CTI Allow Control of All Devices and put it back. Router eqivilant of a shut/no shut...HAHA

Next question is did the DMA import from 4.1(3) screw this up.

I did notice that it keeps all the speed-dials and pretty colors the receptionists who have too much time on their hands like to customize the console with and when I deleted all config to rebulid it all of that customization was lost. So unless you want to hear all the whining I wouldnt sugest deleting the entire config.

I will rebuild this in the lab tommorrow and post the results.

snooter Thu, 02/07/2008 - 13:59

I just finished an upgrade to 6.1.1 from 4.1(3) as well. I right away had issues with the AC.

Long story short, I went into the sevice parameters for the AC service and made both the "JTAPI" and "Device Authentication Application" usernames the same. So, I have a single AC account that associates with all the pilots and phones. Grant the proper CTI security, which you've already done, and it should work like a champ. Just thought I'd share the part about changing the service parameters to the single username. Made it alot less confusing for me!

I'm having a heck of a time with a very slow and unresposive attendant consoles now on the new version!

akascarface Thu, 02/07/2008 - 15:47

I just found this bug:

CSCsi60111 Bug Details Bug #17 of 18 | < Previous | Next >

CM6:0: AC not working after upgrade from CM5.1 to CM6.0.0.9971-2


On CM upgrade from CM5.1 to CM6.0.0.9971-2, Attendant Console isn't working with a "Intialisation of call control failed". Pilot point wasn't registered as well.


CM upgrade from CM5.1 to CM6.0.0.9971-2


Reset the ac user password in CCMAdmin and restart the TCD service on all nodes. Restart consoles.

It says fixed int 6.1.1000, I installed 6.1.2000 but maybe it's back worth a try. I'll test it tommorrow when I rebuild.

paul.higgsboyo@... Fri, 02/08/2008 - 04:44

OK, as the Cisco manual is as usual complex and inaccurate here is how to get the Attendant Console up and working:


Create AC user account


Create AC Pilot number

Give directory number

Set Partition

Set CSS (ensure CSS has access to all other device partitions)

Save and return to configure pilot group

Add hunt users

To add AC user lines select User Memeber in pop up window then use bottom two drop down boxes

Select save then close

To add futher users repeat last 3 steps

Save changes

Note that the pilot point is not registered yet


Create ac Application User account

DO NOT add any devices, pilot points or route points

Just create it and save it


Go to User Groups

Enter "standard cti" as the search criteria and click find

Add the ac application user account to the following user groups:

Standard CTI Enable, CTI Allow Call Monitoring, CTI Allow Call Park Monioting and CTI Allow Control of All Devices


Go to Cisco Unified Serviceablity

Go to Tools>Control Centre - Feature Services

Select server that Cisco CTIManager and Cisco CallManager Attendant Console Server are running on and restart the two services


If you go back to the pilot point it should now be registered


Install the Attendant Console software on the receptionists PC

Enter the CallManager's IP address the above services are running on and the DN number of the receptionists phone

Then enter the AC user account and password that you created at the start

As soon as call control has started, go online and all should be working.


That just about sums it up. Why cant Cisco put out simple instructions like this eh??

akascarface Fri, 02/08/2008 - 11:00

Hey everyone so I told you I'd reload my environment and test and report back...well guess what....

****** This bug is back in 6.1.1(2000)*******

CSCsi60111 Bug


The big ID said it was fixed in 6.1.1(1000) apparently they must have used some bits of code from a previous ver prior to build (1000) for build (2000) and now its back.


Per the workaround of the bug all I did was change the PW of the "ac" account then bounce the ACServer and CTIManager Services and it came right up. No hesitations.

Again this bug is related to upgrading from 4.1 using the DMA import and call control not establishing right after the upgrade.

Tommer Catlin Sun, 06/29/2008 - 20:42

Nice job. Although, I did what you did, but I had to add in my devices still to control or associated them. The AC would not control my front desk phone otherwise. But as soon as I added those groups in, my Pilot point registered.

I read (2) different documents.... all wrong. This helped!


akascarface Mon, 06/30/2008 - 07:59

PS: you have to make the password = password

any other password like abc1234 wont work. Good luck guys.

akascarface Mon, 06/30/2008 - 19:24

Huh!..well I stand corrected then. I tried using something other than "password" but I couldnt seem to get it to work. I'm just glad your issue and mine are gone.

alexjr Mon, 07/07/2008 - 00:47

There were a couple of things I did that fixed my ac. I used "password", 12345 did not work. Also, CTI manager had to be on in the same server that the AC service was on. I thought I had read somewhere in the docs that as long as the CTI manager svc was active on the pub it should work. I turned on CTI mgr and AC svcs on the same server and it worked.


This Discussion