VLAN Question

Unanswered Question
Jan 18th, 2008

I set up a new VLAN on a new 3550 switch in my network that is in a different location and I cannot communicate with the other switches/routers or VLANs or the internet. I configured my new switch on the same vtp domain. I do not see the new vlan propogating to the other devices or vice vera i.e. cannot ping in or out. Also, My VoiP phone are not being configured from vlan 10. Here's my sh int trunk:

Port Mode Encapsulation Status Native vlan

Gi0/1 on 802.1q trunking 1


Port Vlans allowed on trunk

Gi0/1 1-4094


Port Vlans allowed and active in management domain

Gi0/1 1,40


Port Vlans in spanning tree forwarding state and not pruned

Gi0/1 1,40




Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Hieu Cao Fri, 01/18/2008 - 12:28

When you say that the 3550 switch is in different location, what exactly do you mean? In the same building on different floor, or at a different site over the WAN separated by a router?


From your config, your voice vlan is 40, not 10 as you indicated though.


You've 3 interfaces setup as "trunks". Which one is really being used as a trunk link to another switch?


Try adding "switchport mode access" to all non-trunking ports.

marc_eli4 Fri, 01/18/2008 - 12:33

The 3550 switch is in a different off site location connected through metro-ethernet. I can now ping to vlan 30 and 20, but not backward. Still no config to my phone.


Here is a working vlan's interface:

Working VLAN:

interface FastEthernet0/1

switchport mode dynamic desirable

switchport voice vlan 20

spanning-tree portfast


The only difference seems to be the switchport mode desirable line vs. the no ip address line for the non working vlan.

marc_eli4 Mon, 01/21/2008 - 12:52

VLAN 40's ip is 10.4.x.x so it is still part of the 10 voice network

glen.grant Mon, 01/21/2008 - 13:39

I don't see where you are running any kind of routing protocol so you would need explicit static routes for all the networks on this 3550 from other locations if they aren't already there.

marc_eli4 Mon, 01/21/2008 - 14:22

Thanks for the reply glen,

I basically mirrored a config from another location's switch and changed a few parameters for this switch, all the static routes are already configured.


How do I get the default command line "switchport mode dynamic desirable" back on all the interface ports instead of the command "no ip address"?

glen.grant Mon, 01/21/2008 - 17:50

Not quite sure of the question but if you want it as a access port and not a routed port then just add the command "switchport" on each interface you want as a access port . This changes it from a routed port to a access port . If this is not what you are asking maybe you can clarify , thanks..

marc_eli4 Tue, 01/22/2008 - 09:01

I issued the switchport command but it does not change the "no ip address" line on my interfaces


Ex: This is how I want the interface to look

interface FastEthernet0/1

switchport mode dynamic desirable

switchport voice vlan 40

spanning-tree portfast


Instead of:

interface FastEthernet0/1

switchport voice vlan 40

no ip address

spanning-tree portfast


marc_eli4 Wed, 01/23/2008 - 13:54

I can ping 10.2.0.1 and 10.3.0.1(both at different locations) from the router, but I cannot ping 10.4.0.1. I added the necessary commands to the router, but no luck. When I initially connected the new 3550 switch, the new vlan propagated to the other switches(at different locations) but I cannot ping to or from those switches. Is the problem related to the router not being able to ping the new vlan?


Correction: the new vlan did not propagate to all the other switches. However, when I attempt to manually add the vlan, I get: "Error exiting config-vlan mode 39: NV storage failure"

marc_eli4 Thu, 01/24/2008 - 08:22

That is vlan 10 on interface 10.2.0.1 and 10.3.0.1. Is there a bridge that needs to be configured to allow address 10.4.0.1?

marc_eli4 Fri, 01/25/2008 - 08:42

I put a static routes into the router for the new vlan:

ip route 10.4.0.0 255.255.255.0 FastEthernet0/0.10 and


ip route 192.168.40.0 255.255.255.0 192.168.1.58


I can ping from my hosts in each vlan to their gateways; from the new switch I can ping the 10 interface but not the 192.168.40.1 interface. My Voip phone cycles as if it wants to contact the voice vlan, but it never gets an ip and just keeps cycling


I can ping to/from one vlan to the other on all the other switches except this new one(neither in or out)

scollins34 Sun, 01/27/2008 - 05:12

Just from the sound of what you have wrote you may have set the new switch in VTP Mode Transparent. Which makes the neither synchronize or advertise its configuration

marc_eli4 Mon, 01/28/2008 - 06:27

The new vtp revision is not propagating to all the switches. Some have a Configuration revison of 18 and some have 16. Also, I cannot ping vlan10 from my new vlan.

marc_eli4 Mon, 01/28/2008 - 13:04

Progress finally...My VoiP phones are working. And I can ping to and from the new vlan interface. However, when I connect a laptop and assign it an ip within that vlan, I can't get to the internet. I can ping out just fine, but nothing else on the network can ping the laptop???? Also, if I assign an IP from another vlan, I can get to the internet just fine.

marc_eli4 Tue, 01/29/2008 - 12:04

Update...I can now get to the internet only through the proxy server. But I am still having an issue ping to this workstation. It can ping out just fine.

marc_eli4 Tue, 01/29/2008 - 12:52

Also, I am able to ping the VoIP phone connected to that vlan switch, but not able to ping the pc.

marc_eli4 Tue, 01/29/2008 - 15:53

I finally got it to work. It was basically an issue with the PC I was using(maybe a bad NIC?), anyway I connected another laptop to the switch and it works fine, can ping both ways and get to the internet without the proxy

Actions

This Discussion