Cisco 3620 + Ethernet 4E - DHCP Only working on one interface!

Unanswered Question
Jan 19th, 2008

Hi Guys, I just got an Ethernet 4E card for my 3620 and only 1 Interface at a time seems to be grabbing an IP Address from DHCP

All 4 interfaces are set to DHCP and no shut.

"Cisco3620#sh ip int brief

Interface IP-Address OK? Method Status Protocol

Ethernet0/0 unassigned YES DHCP up up

Ethernet0/1 10.30.0.1 YES NVRAM up up

Ethernet0/2 10.29.0.15 YES DHCP up up

Ethernet0/3 unassigned YES DHCP up up

BRI1/0 unassigned YES NVRAM administratively down down

Ethernet1/0 unassigned YES DHCP up up

Serial1/0 unassigned YES NVRAM administratively down down

BRI1/0:1 unassigned YES unset administratively down down

BRI1/0:2 unassigned YES unset administratively down down

Tunnel0 192.168.6.2 YES NVRAM up down

Tunnel1 192.168.15.2 YES NVRAM up down"

Below is my config:

Cisco3620#sh run

Building configuration...

Current configuration : 1510 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Cisco3620

!

boot-start-marker

boot-end-marker

!

enable password 7 ####

!

no aaa new-model

ip subnet-zero

!

!

ip cef

!

ip dhcp pool Wireless(Eth1)

network 10.30.0.0 255.255.255.248

default-router 10.30.0.1

domain-name w1.ap1.noe.home

lease infinite

!

interface Ethernet0/0

description LAN

ip address dhcp

half-duplex

!

interface Ethernet0/1

ip address 10.30.0.1 255.255.255.248

half-duplex

!

interface Ethernet0/2

ip address dhcp

half-duplex

!

interface Ethernet0/3

ip address dhcp

half-duplex

!

interface BRI1/0

no ip address

encapsulation hdlc

shutdown

!

interface Ethernet1/0

ip address dhcp

half-duplex

!

interface Serial1/0

no ip address

shutdown

!

ip http server

ip classless

!

gatekeeper

shutdown

!

!

line con 0

line aux 0

line vty 0 4

password 7 ###

login

!

!

end

Running IOS: c3620-ix-mz.123-17a.bin

Any idea's?

Cheers, Mike.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Istvan_Rabai Sat, 01/19/2008 - 08:03

Hi Mike,

Please provide info about how you are connected to the DHCP server with the Ethernet cards not succeding with getting an IP address.

General problems with DHCP may include the following:

1. Failure to configure a DHCP relay agent if the client is not directly connected to a DHCP server

2. No backward route in the routing table from the DHCP server to the subnet where the DHCP request came from.

3. Failure to configure excluded addresses in the DHCP server for addresses that are already assigned manually to default gateways or other hosts.

The DHCP server of course tries to assign an IP address from your range defined in the "network" command under the "dhcp-config" prompt, generally the first usable one in the specified subnet. If this IP address is already assigned manually on the subnet, ensure that this address is excluded from the DHCP pool with the "ip dhcp excluded-address" global config command.

Please verify these and inform me about your success.

Best regards:

Istvan

Edison Ortiz Sat, 01/19/2008 - 08:52

You are connecting the other LAN interfaces on different Vlans? If so, do you have a ip helper-address on the gateway from that Vlan so dhcp request can be forwarded to the server ?

If they are on the same Vlan, that design won't work. They need to be on separate Vlans.

Also, provide the model of the 4Port Module.

__

Edison.

glen.grant Sat, 01/19/2008 - 09:50

Please explain what you are trying to do . Are you thinking the actual interfaces on the router are going to pull an address ??? I only see one dhcp pool of 7 addresses defined . Probably devices on E0/1 are working correct ?

Edison Ortiz Sat, 01/19/2008 - 13:23

Glen, I was thinking about the same thing. The IP address he wants aren't being generated by the router's DHCP. If you noticed E0/2, the subnet is not on the pool therefore I assume it was generated by a separated DHCP server.

Very odd config, I must say.

__

Edison.

Istvan_Rabai Sun, 01/20/2008 - 02:16

Hi Edison,

I interpret this config the same way.

He wants to get the IP addresses from a different DHCP server.

At the same time this router acts as the DHCP server for the wireless clients.

Istvan

Actions

This Discussion