7960s De Registers on CUCM 6.01a

Unanswered Question
Jan 19th, 2008

Trying to find out why I have some 7960's de registering by themselves...

Wireshark shows keep alives at the regular intervals... then all of a sudden, 2 seconds after the last keep alive I get

a Skinny un-register message from the phone to the CCM . Then a FIN from the phone to the CCM and a FIN from the CCM to the phone.

i've attached the capture of packets for people here to see.

right now the phone is on SCCP 8.0.7, i've tried 8.0.5 as well, still happens.

the system has 25 phone's on it, it's definatly not over burdened.

in RTMT the trace is showing a reason code of 8 for why it deregistered -- which is missing Keep alives... I'm expecting that, because the phone closes it's connection and stops sending -- so the CCM kills the connection.

The phone comes back by itself after about 3-4 minutes...

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Ayodeji oladipo... Sun, 01/20/2008 - 08:30


First of all the reason code of 8 does not mean loss of keep alives...it simply means:

A DeviceInitiatedReset..from this link


You can get a cleare picture of why the device unregister if you look into the BackUP CCM in your cluster to which the device must have registered to after it unregistered with the primary server....

There is a string int he CCM trace which begins with last= It will tell you the reason why the IP phone unregistered with its orimary CCM...

The way IP phones work is that before a phone registers with a CCM it sends a station alram message to the CCM..If it is a normal registration the alarm message is baln, but if it is due to an error the phone will give you a reason for this happening...

Having said that, If you see a string in the last=TCP-CLOSED...This means that the TCP connection between the CCM and IP phone was closed...This is not as a result of loss of keep alives..because keep alives ride on TCP..so the keep alive never made it to CCM server in the first place.

A loss of keep alive is indicated by the string last=KeepalivesTO ( which means there is TCP connection but CCM is not responding to the keep alives sent to it by the IP Phones..

You will need to look at your network to solve this type of issues. I recently had this problem and it was due to a wrong duplex setting on my router interfaces, which cause my interface to reset frequently..

Let me know how it goes...

On the sides, How were you able to use wireshark to filter only the traces between the IP phone and CCM. I used wireshark recentl and I had loads of information...Thanks

justincohen Sun, 01/20/2008 - 14:05

Wireshark allows filters.

I captured everything then filtered only what I needed, when I saved it, I said save only displayed.

you make some good points, however there's only one CCM on this system, with an SRST as backup, will SRST also log those?

Ayodeji oladipo... Sun, 01/20/2008 - 14:10

I am not sure SRST will log this.

However if this is the only phone having this issue, then I suggest you take a look at the port on the switch to which the ip phone is connected to...or move the phone to another port...and see what happens

Ayodeji oladipo... Sun, 01/20/2008 - 10:04

taking a closer look at your capture, this lloks like a problem with the IP phone. Because there was no TCP connection broken or missed keep alives.

Look at the IP phone itself since it is the only one on your network having this issue.

A TCP connection problem will look like this..a sample capture is attached

justincohen Sun, 01/20/2008 - 14:08

Interesting you said that..

I have started investigating further.

This may be related in SOME WAY to a switch issue. It's almost as if the CCM is sending the keepalives back but they are not actually reaching the phone itself.

There is a small 16 port switch in the equation, when I bypass it, the phone works fine. I tried another switch, it also does the same thing.

Now here's the REAL kicker. All I did was go from CCM4 to CCM6, in CCM4, it worked fine.

So i'm wondering if there is some CDP or something going on, and the phones think they are directly connected to a cisco switch in some way, and then they get confused when it hears other traffic.

bottom line is, I upgraded CCM and now i've got network problems? Weird.

aramos17428 Tue, 06/17/2008 - 10:49


I was wondering if you ever got your problem with the phones unregistering fixed. I did an upgrade from CCM4 to CCM6 and now I have phones unregistering. Cisco is saying that it is a network issue (not enough bandwidth) however everything was working fine before the upgrade. Thanks for taking the time.

A. Ramos


This Discussion