7970G not pulling down firmware

Answered Question
Jan 21st, 2008

Hi,

I've got an issue with a factory-reset 7970G, it's receiving it's new IP address from the DHCP server without an issue (192.168.3.99) but it doesn't appear to make any subsequent requests to the server for the latest files, could anyone suggest why this may be?

Thanks,

Tim

I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 8 years 10 months ago

Glad to know it helped. Please remember to rate useful posts with the scrollbox below!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
timgaunt82 Mon, 01/21/2008 - 02:43

Hi,

I don't think so but the DHCP server is on the same server.

Tim

timgaunt82 Mon, 01/21/2008 - 03:09

I beleive so yes, we only have a single server in the office. I'm not the person that set it up so I apologise if I'm a little sketchy on some of the details.

For what it's worth we have another Cisco phone in the office which updates fine, this one gets the IP and says "Upgrading" on the middle box but the bottom box that usually has details of the files being transferred is blank.

Tim

timgaunt82 Mon, 01/21/2008 - 04:42

I've just contacted the guy that set it up for us and he says they are different servers and Option 150 is set ok.

The issue appears to be with the phone as he says it's not making a request for the SEP.cnf.xml file? Does that make sense?

Tim

Paolo Bevilacqua Mon, 01/21/2008 - 04:54

To prove that phones is not making the request, you should need to sniff on the network. On the other hand, if it is not doing the request, it would not even register. Does it registers ? What are the CM settings for that device ?

timgaunt82 Mon, 01/21/2008 - 05:10

I've done that and other than getting the IP there's no traffic, I was using Wireshark, is there a more stuitable alternative?

The phone was factory-reset so AFAIK there are no new settings.

Tim

Paolo Bevilacqua Mon, 01/21/2008 - 05:25

Does the phone do the DHCP request repeatedly ?

Such would be a sign that it doesn't like it.

Also try the alternate reset sequence: 3491672850*#

timgaunt82 Mon, 01/21/2008 - 05:31

Yes it does! I can see it making a request every few minutes. The IP is 192.168.3.99 what would be a better IP?

That alternative reset sequeence doesn't appear to do anything -and then after a while the lights flash red instead of orange :S

Tim

timgaunt82 Mon, 01/21/2008 - 05:37

Ah, I've just cleared the DHCP pool and it's picked up the firmware without an issue. The issue now however is since doing the alternative reset the screen has turned off?

Tim

timgaunt82 Mon, 01/21/2008 - 05:39

Ah don't worry, it appears to have come back to life :)

Thanks for your help, you were right, it was an issue with the IP address.

Tim

Correct Answer
Paolo Bevilacqua Mon, 01/21/2008 - 06:09

Glad to know it helped. Please remember to rate useful posts with the scrollbox below!

Paolo Bevilacqua Mon, 01/21/2008 - 05:37

Every few minutes it's normal, as it is re-attempting initialization. You should definitely see a TFTP request, however at this point also look in the DHCP reply and check that option 150 in in there.

Actions

This Discussion