Performance issues with CSS 11501

Unanswered Question
Jan 21st, 2008
User Badges:

Hi,


We have installed some CSS 11051 Load balancers in an oracle solution. One of those load balancers supports three pairs of servers PORTAL, OCS & SSO.

We are facing performance issues. It seems that each time both servers are up they communicate throught their VIP and these cause performance decrease.

The only solution is to stop one server of each pair.


The configuration is attached.


Please advise


Best Regards

Samy J. Chapoutot



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Diego Vargas Mon, 01/21/2008 - 04:58
User Badges:
  • Cisco Employee,

Hi Samy,


Your configuration is not really large so I would not expect to see these kind of issues.


Would you be able to upload a showtech in order to investigate further.


Also when you say that both servers communicate throught the VIP you mean requests that need to be balanced or every single traffic between the two servers is going thru the VIP?


It would be useful to have a network diagram as well or at least a good idea of what devices are part of the scenario in front and back of the CSS.

chapoutots Tue, 01/29/2008 - 00:51
User Badges:

Hi,


sorry for the delay in submitting my reply due to site issues.


I have changed the configuration in order to set persistency by adding the two following lines

" advanced-balance sticky-srcip

sticky-inact-timeout 120"


As I said previously it seems that every traffic coming to the VIP (from client) is firstly redirected to a server which to be able to reply, will contact the vip (based on dns names) and will be balanced to the second server. Adding the two lines has had a significant impact, the vip redirects a traffic from a server to itself.


I don't know how to upload a showtech. You will find a graphic enclosed showing the network diagram.


Please advise

Regards



Attachment: 
Gilles Dufour Wed, 01/30/2008 - 01:29
User Badges:
  • Cisco Employee,

before clicking everywhere and changing every device config, I think it is important to understand the behavior of the server and why it behaves like this.

The CSS does not control the server and why this one open a connection back to the vip.


Talk the server admin guy maybe.


Also, what would be interesting is a sniffer trace between css and server when there is only 1 server and when there are 2 so we can see if there is a difference.


Gilles.

b.petronio Wed, 01/30/2008 - 03:20
User Badges:

"I don't know how to upload a showtech."


Enter the following command, "script play showtech".


After that, it will be stored in the log, and u could screen it, with the "show log showtech.out" command.


Best Regards,

Bruno Petrónio

chapoutots Fri, 02/01/2008 - 05:38
User Badges:

Hi,


please find enclosed the showtech.out file.

I have noticed better access to servers by removing the "phy 100Mbits-FD" clause.


Please advise


Best Regards

Samy J. Chapoutot



Attachment: 
b.petronio Fri, 02/01/2008 - 08:27
User Badges:

Check out the interface errors FCS... U have lot of errors in the showtech. Find "ether-errors", in the show tech.


If u have configured 100Mbits-FD in the one CSS interface, u should have 100Mbits-FD (FD - Full-Duplex), in the other side, directly connected server NIC's or switch ports.


If u have switch's connected in each interface, u could search for interface errors in each interface connected to CSS.


A simple test could be done, by performing a extended ping from the servers to the css ip interface.

U should see some timeouts.



!!!!!!!!!!!!!!!!!!.!!!!!!!!!!.!!!!!!!!!!..!!!!!!!!!!!!


Hope it helps.

Best Regards,

Bruno Petrónio



Actions

This Discussion