"Ring Out" shown on IP Phone but no ringing tone

Unanswered Question
Jan 21st, 2008

Hi,

I am having a problem where i have a QSIG connection between a Cisco 3845 and a Nortel Option 11C PBX. This router is configured as H323 registered to a CallManager 4.2(3)

When I use an IP phone and dial to a nortel phone.

The nortel phone is ringing, but I do not hear the ringing on the IP phone. There is a message "Ring Out" on the IP phone.

When I do a debug isdn q931 on the router, this is what I see:

Router#

Jan 21 23:33:36 SG: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x16 is 0x0 0x0, Calling num 83181713

Jan 21 23:33:36 SG: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x16 is 0x0 0x0, Called num 1708

Jan 21 23:33:36 SG: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8 callref = 0x0006

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Calling Party Number i = 0x0081, '1000'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '2000'

Plan:Unknown, Type:Unknown

SGHQGA2-3845#

Jan 21 23:33:36 SG: ISDN Se0/1/0:15 Q931: RX <- SETUP_ACK pd = 8 callref = 0x8006

Channel ID i = 0xA98381

Exclusive, Channel 1

Jan 21 23:33:36 SG: ISDN Se0/1/0:15 Q931: RX <- CALL_PROC pd = 8 callref = 0x8006

Jan 21 23:33:36 SG: ISDN Se0/1/0:15 Q931: RX <- ALERTING pd = 8 callref = 0x8006

Locking Shift to Codeset 5

Codeset 5 IE 0x32 i = 0x81

Here is a partial Configuration of the QSIG connection.

interface Serial0/1/0:15

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache cef

no ip route-cache

no logging event link-status

isdn switch-type primary-qsig

isdn protocol-emulate network

isdn incoming-voice voice

no isdn T309-enable

isdn T310 120000

no cdp enable

Hope someone can help on this.

Thanks,

Eugene

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
PETER NEGUS Mon, 01/21/2008 - 08:43

This may be that old chestnut "isdn progress indicators". Try

progress_ind alert enable 8

under the outbound dial peer.

You may also need

progress_ind setup enable 3

on the inbound dial peer if there are ringback problems the other way

eug-c Mon, 01/21/2008 - 09:15

Thanks both, I will try this out. :)

Appreciate it.

Eugene

eug-c Mon, 01/21/2008 - 09:32

Thanks!

The progress_ind solved the problem.

The H225 service parameter had no efffect.

Thanks all!

learnt something today.

:)

Eugene

Actions

This Discussion