How do you change voice speed for IPIVR with Nuance TTS

Answered Question
Jan 21st, 2008
User Badges:

IPIVR 4.0(5) with external Nuance TTS server. I'm trying to change the voice speed as it is too fast. I am told I need to use SXML in CRS. Don't have any clue how to do this at all. Anyone?

Correct Answer by BCOLE2007 about 9 years 3 months ago

Try this to set your default rate


1)Navigate to your MRCP server config file

or search for OSSserver.cfg on your TTS server


2)Open the file

look for defaultRate

change the number on this line to something lower than what it is, the default is 50

save the file


3)Restart the service SpeechWorks MediaServer

on the TTS server


the new rate should take affect, some may complain of a 'gurgling' sound in some words on the voice


we have bounced back between 50 to 35, now at 45


let me know how it turns out

and don't forget to rate posts

Blair

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Riccardo Bua Mon, 01/21/2008 - 13:59
User Badges:
  • Cisco Employee,

Hola,


I would assume you are using Vocalizer 3.x.


By modifying a Nuance configuration file, cf02_appcfg.txt, we can alter the

speed. But this value will affect both the genders, we do not have the

ability to change the speed for each voice. The tag to be modified in this

file is SPEAK_RATE. The default setting is 100. Nuance suggests using a

range of 50 through 150. A value of 50 means the speech duration will be

half that at 100. The value of 150 means the duration will be 50% longer

than that at 100.


For en-US voice used in North America, the .txt file to be modified is

located under c:\Nuance\Vocalizer3.0\data\en-US\config\mulaw. The engine

needs to be restarted after these changes are made.


To work with provisioning your system with some scripts please refer to the Dev Guide:


http://www.cisco.com/application/pdf/en/us/guest/products/ps6488/c1626/ccmigration_09186a00804a2b0d.pdf


Regards,


Riccardo


PS. Please remember to rate useful posts


SAN J Mon, 01/21/2008 - 14:25
User Badges:

Thanks Riccardo. The Nuance App I'm using is actually RealSpeak 4.X. I would hope there is an equivalent config file I can edit to change the speed rate? I'm not onsite so I can't check it quickly but I will when I get a chance.

Correct Answer
BCOLE2007 Thu, 01/24/2008 - 12:25
User Badges:
  • Bronze, 100 points or more

Try this to set your default rate


1)Navigate to your MRCP server config file

or search for OSSserver.cfg on your TTS server


2)Open the file

look for defaultRate

change the number on this line to something lower than what it is, the default is 50

save the file


3)Restart the service SpeechWorks MediaServer

on the TTS server


the new rate should take affect, some may complain of a 'gurgling' sound in some words on the voice


we have bounced back between 50 to 35, now at 45


let me know how it turns out

and don't forget to rate posts

Blair

Actions

This Discussion