Webview Error - Service Unavailable

Unanswered Question
Jan 22nd, 2008
User Badges:

Hi,


We have installed the Webview with ICM 7.0. Followed the exact procedures as per the Webview installation and administration guide. The installation does not return any error in between and completed successfully.If we try to access the webview for the instance ,it returns "Service Unavailable" and didn`t even display the login page. Could somebody advise as what might be the problem here?


Raj

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Zin.Karzazi Tue, 01/22/2008 - 04:29
User Badges:
  • Silver, 250 points or more

you tried http://IP/instance_name ??

Stop IIS Admin Service, Jaguar and WWW Publishing Service. Restart IIS,Jaguar and WWW Publishing Service see if it helps.


dchumbley Tue, 01/22/2008 - 08:41
User Badges:

I had the same issue when I upgraded to 7.2.2. If that is your version make sure you have the latest SR. I had a case open last Nov and then fix then was ES 2 for 7.2.2.

bill.king Wed, 01/23/2008 - 07:33
User Badges:

Dumb question, but do you get the same message when you try it as just http?

rajasekarvs Wed, 01/23/2008 - 17:50
User Badges:

That`s the basic level of troubleshooting...:( We are getting the same error even when we try it as http. You know what ? We are able to get the ssl certificate challenge ,when we try with even https.So there is no problem with at the web service level.


Raj

Patrik Englund Wed, 01/23/2008 - 22:26
User Badges:

Are you trying to access webview from a client computer or have you tried this locally on the webview server? Also check if you have sssl enryption activated by starting sslutil.exe in c:\cim\bin driectory on your webview server. Is there any firewall blocking ioncoming requests to webview? Ports then needs to be opened between webview and AW server. One other thig to check is if there is any difference if you add the port in the adress :


https://localhost:443/citi

http://localhost:80/citi

http://localipadress/citi


Some troubleshooting can be found here :

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/enterprise_reporting/reporting7_0/installation/guide/wipce70i.pdf



Good luck!

rajasekarvs Wed, 01/23/2008 - 23:16
User Badges:

Hi Patrick,


We have already tried eveything that you have quoted above and nothing worked.

On observation , we do get the attached error in the Windows eventviewer "The HTTP filter dll ServletExec_ISAPI.dll failed to load".


Raj

Zin.Karzazi Thu, 01/24/2008 - 01:09
User Badges:
  • Silver, 250 points or more

Can you please check if the ServletExec_ISAPI.dll exists on you IIS:

Go to IIS Manager-> Server Name-> Default Web Site/Scripts/ServletExec_ISAPI.dll



rajasekarvs Thu, 01/24/2008 - 02:46
User Badges:

Hi,


The ServletExec_ISAPI.dll is there in the mentioned directory as well.


Raj

fabien.damien Fri, 05/08/2009 - 01:10
User Badges:

Hello Raj,


where you able to solve this problem?


Thanks for the feedback,


Fabien

joesnyde Fri, 05/08/2009 - 08:46
User Badges:
  • Cisco Employee,

Hello Raj


Are you able to open the Webview on the server using the following


http:///


Is SSL enabled, if so use


https:///


When you installed Webview was this installed before or after SR 4 was installed. You must install 3rd Party Tools and Webview at the base ICM 7.0 with no SRs installed.


Another issue could be MS09-014 (KB 963027), their is a known defect that may be causing the issue. If this MS patch is installed try removing the patch.

rajasekarvs Fri, 05/08/2009 - 09:02
User Badges:

Hi,


Yes, we were able to get it` resolved. the issue was due to some permission related issues on the IIS.


Raj

Actions

This Discussion