CUCM Password Recovery

Unanswered Question
Jan 22nd, 2008

Hi,

is there the posibility to recover or change the Callmanager Application Admin password (for the administrative web pages) after a new Callmanager installation.

Note: I can access the OS Administrator webpage because here the Username and passoword does work. But I cant access the CM Administration and Serviceability.

Best regards

Moe

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
r.stockton Wed, 08/13/2008 - 15:38

hmmm...I've run into a situation where I'm no longer able to access the CCMadmin page after changing IP address.

So, I've ssh'd into the box and issued the command..here's what I get:

admin:utils reset_ui_administrator_password

New password:

Confirm new password:

-------------------- utils reset_ui_administrator_password --------------------

Reset user interface password

Passwords do not match, run the command again.

admin:

*************

Oh, I've tried this a dozen or so times...there's no WAY, I can mess up that many times!

Suggestions?

Can this be changed by booting to a live-CD and access the filesystem directly?

This is currently in a lab environment running on VMWare so I suppose I could easily blow it away, however...i'm curious and would like to figure out a fix in case it happens 'live'.

regards,

-r

espereir Wed, 08/13/2008 - 16:14

Hello Robert,

The problem might be the password that you are trying to set, I always set it to [email protected] and after I am logged in the web, I change it from Application Users page.

The utils reset_ui_administrator_password will not accept trivial passwords and will request different char types.

If it still fails, you can run the following query from CLI (all is just one line):

run sql update applicationuser set password='f3f84fcd7934cd48ef4fef0d9057c21d000ffe229fbd0a247ee491927aa30f02' where name='CCMAdministrator'

This will set the CCMAdministrator password to "ciscocisco".

Hope this helps!

r.stockton Wed, 08/13/2008 - 18:33

No joy. I still get passwords do not match error. I tried [email protected] numerous times, [email protected], RJSccm#012. Is there a file within the file system that I can edit? I can boot to a live CD and access the actual linux portion.

It should be noted that the password became corrupted whilst I was performing admin functions (looking up gateways or devices, IIRC). I received an error (should've written it down) and shut down my browser and then was unable to logon to ccmadmin.

Additionally, I tried the run sql update command you posted. This gets me:

Failed to get Connection.Connector(NOT CONNECTED: Driver=com.informix.jdbc.IfxDriver;)

Note: I am attempting this on UCM 6.1.1 sho the SQL command may not be relevant to this version.

It's a head scratcher

espereir Fri, 08/15/2008 - 08:44

Hello Robert,

I am afraid that you are having database access problems, please try to restart the service after working hours in order to see if we can reset the password (you shouldn't get the informix DB access error); if the issue persists, it is possible that the issue is a replication problem; so please issue the utils dbreplication status command and check the output with the file view activelog command, if replication status is other than 2, follow the steps below after working hours in order to restore it:

a. utils dbreplication stop (on subs first)

b. After the subs are done, run the same command on the pub

c. utils dbreplication clusterreset

d. It will print out a log file for you to monitor. Keep reading this file and see if it fails.

d.i. If it fails, it should tell you which node failed and the action to take.

d.ii. Most likely it will tell you drop the syscdr DB on one of the nodes

d.iii. If you need to drop a syscdr DB on a node, proceed to the next step

e. utils dbreplication dropadmindb (one whichever node reported was failed in the previous step)

f. Re-run utils dbreplication clusterreset

g. At last, issue the utils dbreplication reset all from the Pub.

Hope this helps!

Steellllllllll0 Mon, 08/18/2008 - 04:39

This is the message i am getting back from trying to reset the password :

Reset user interface password

Failed to get Connection.Connector(NOT CONNECTED: Driver=com.informix.jdbc.IfxDriver;)

08/18/2008 13:34:24.282 | Update FAILED: code = 1, AUTHORIZATION FAILURE

admin:

r.stockton Mon, 08/18/2008 - 06:48

A couple of things:

1) This is only a PUblisher

2) Nonetheless, I still ran the utils dbreplicatino status to see what it looks like. When doing "file view activlog ", how do I find the path to the log file?

At any rate..I'm performing the dbreplication commands nonetheless...just to see what happens.

Finally, this is a non-production vmware box (I don't wish to waste anyone's time focusing on something that is most defininately not critical). I could very easily blow this whole thing away and start from scratch (in less time). I purely am troubleshooting this for the sake of learning. The problem cropped up...and, well, I'd like to see this to resolution - who knows, a real Customer might actually have this issue one day :)

espereir Mon, 08/18/2008 - 09:05

Hello Robert,

The utils dbreplication status command will tell you the path of the log file.

Thing is, that for some reason CLI is not able to access the database, please try to reset the security password and restart the node: http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/rel_notes/6_1_2/cucm-rel_note-612.html#wp425636

You can also try to restart the service by CLI:

utils service restart Cisco Database Layer Monitor

And then try to change the password again.

Let us know how it goes!

espereir Sat, 09/29/2012 - 22:29

Hi Mohammed,

I do not have the DDTS handy, but CUCM 8 is also affected, and the steps to resolve are similar to the ones that I have posted above, if you have a cluster, you should check replication first, if it is not it might be related to the DB Layer Monitor service, there are plenty DDTS related to lockouts some of them are caused by FileSystem permissions, some others related to the DBL, you can try and restart the DBL service and if that fix the issue please consider upgrading to the latest release of 8.6.

Regards,

espereir

Hi Espereir,

Thanks for your reply. I have tried everything you have mentioned, all the password reset passwords and all db replication commands too. I am running a small lab, which is not real-time, so no need to upgrade, However, when I run the db related commands, eg, utils dbreplication replair, it says, the dbreplication repair can not happen becuase the replication is down or something similiar to this,

I know from this that the db replication is down, which needs to be make up and running.

Any idea with db replication not able to repair?

how I can resolve this? Obviously I just need the CUCM Admin GUI password only.

espereir Sat, 09/29/2012 - 23:35

Additionally, since this is a SQL query, you can replace the accound name to whatever your Admin account is, just replace CCMAdministrator with your account user ID, just replace CCMAdmin and leave the single quotes (no spaces).

run sql update applicationuser set   password='f3f84fcd7934cd48ef4fef0d9057c21d000ffe229fbd0a247ee491927aa30f02'   where name=''

If you do not remember the web admin account that was typed during setup, you can list all the Application accounts with the following command:

run sql select name from applicationuser

That command will list all the application users, you shoud identify the admin username from that list.

HTH

espereir

Hi There,

I have the same issue, i.e. not able to reset the password for CUCM Admin GUI page,

when I run the sql update, it gives me either of the two messages,

1. Column(passwd) not found in any table in the query (or SLV is undefined)

2. Foun a quote for which there is no matching qoute.

My environment is vmware, CUCM8,

Any way, how I can log onto the CUCM GUI Admin page.

Regards,

Saad,

espereir Fri, 01/18/2013 - 00:21

Hi,

The name of the password colum was changed on CUCM 8.X and above, please try the utils reset_ui_administrator_password command first, if that fails, you can use this command:

run  sql update applicationuser set     passwordreverse='69c4f936f9cdf45f6bbca2570c31215629bb5d6fb97493478b8ff3db6fffbc55'     where name=''

This will change the password to c!sco123 ; I tested it on my lab and this was the output:

admin:run sql update applicationuser set passwordreverse='69c4f936f9cdf45f6bbca2570c31215629bb5d6fb97493478b8ff3db6fffbc55' where name='Administrator'

Rows: 1

admin:

HTH

espereir

jeffrey-hughes Tue, 01/22/2008 - 07:00

I had the exact problem this morning. I found the following answer in another thread, and it worked perfectly.

Confirmed by TAC:

1.- Make a ssh through puTTY

2.- When you are in the CLI run "utils reset_ui_administrator_password"

3.- And please type the new password

Good Luck

espereir Fri, 01/18/2013 - 00:22

Try thisone on 8.X and above only if the utils reset_ui_administrator_password command fails:

run  sql update  applicationuser set      passwordreverse='69c4f936f9cdf45f6bbca2570c31215629bb5d6fb97493478b8ff3db6fffbc55'      where name=''

This will change the password to c!sco123 ; I tested it on my lab and it worked

HTH

espereir

Hi Espereir,

The output I am getting is this,

Rows: 0

And the password deos not change,

I have although logged into the server by using the command

utils reset_application_ui_administrator_name

So thanks,

But I would like to know what exactly is the meaning of the sql update that we are running in the above command,

the alpha-numeric string after passwordreverse

thanks,

Saad,

Actions

This Discussion