trying to run axlquery with ccm6.0..plz help

Unanswered Question
Jan 22nd, 2008

Hi,


i was trying to run the axlquery.asp out of the axlsqltoolkit with no success..:-((,

so i ran the java example, after some modifications, and i got all i needed.


but..


i cant run the asp, i guess i m doing something very wrong..


here is what i tried..



var authstring = text2base64(cmUserID + ":" + cmPassword);


var xmlDoc = new ActiveXObject("msxml2.DOMDocument");

xmlDoc.async = false;

var xmlhttp = new ActiveXObject("Msxml2.XMLHTTP");


var sAXLRequest;

var objNodeList,objNode,index;


sAXLRequest = '<SOAP-ENV:Envelope xmlns:SOAP-ENV=\"http://schemas.xmlsoap.org/soap/envelope/\">\n';

sAXLRequest = sAXLRequest + '<SOAP-ENV:Body>\n';

sAXLRequest = sAXLRequest + '<axlapi:executeSQLQuery sequence=\"1\" \n';

sAXLRequest = sAXLRequest + 'xmlns:axlapi=\"http://www.cisco.com/AXL/API/1.0\" \n';

sAXLRequest = sAXLRequest + 'xmlns:axl=\"http://www.cisco.com/AXL/API/1.0\" \n';

sAXLRequest = sAXLRequest + 'xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" \n';

sAXLRequest = sAXLRequest + 'xsi:schemaLocation=\"http://www.cisco.com/AXL/API/1.0 axlsoap.xsd\">\n';

sAXLRequest = sAXLRequest + '<sql>SELECT * from devicenumplanmap </sql>\n'

sAXLRequest = sAXLRequest + '</axlapi:executeSQLQuery>\n';

sAXLRequest = sAXLRequest + '</SOAP-ENV:Body>\n';

sAXLRequest = sAXLRequest + '</SOAP-ENV:Envelope>\n';


xmlDoc.loadXML(sAXLRequest);



xmlhttp.Open("POST", "http://" + ccmserver + "/CCMApi/AXL/V1/soapisapi.dll", false);

xmlhttp.setRequestHeader("Authorization", "Basic " + authstring);

xmlhttp.setRequestHeader("Content-type", "text/xml");

xmlhttp.Send(xmlDoc);


// Return the XML response


return xmlhttp.responseText;


... unfortunately i dont get anything back...


the base64enc works and gives the correct string back..


can someone plz help me??


thanks



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion