LMS 3.0.1 - Displaying full fqdn in emails?

Unanswered Question
Jan 22nd, 2008

Hi there,

Running LMS 3.0.1 on a windows 2003 server enterprise box. I've run into a problem where emails sent out from LMS for jobs do not display the full FQDN.

So in the body of the email, the links are all of the form:


instead of


Is there a setting within LMS 3.0.1 where I can address this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Tue, 01/22/2008 - 11:42

Please post your NMSROOT\lib\classpath\md.properties. If this information is too sensitive to post on an open forum, please open a TAC service request with the same information.

david.fernandes... Tue, 01/22/2008 - 16:11

Thanks, I've got a TAC case going to try and address this issue. They're recommending I try the changehostname.pl.

One thing I noticed when I took a look at the md.properties file was that the following two fields were the same. I would have thought that the PX_FQDN would have the hostname and domain name.



Is this an issue that could have been resolved at installation if the primary DNS suffix for the Computer Name (My Computer > Properties > Computer Name > Change > More) had been set?

Joe Clarke Tue, 01/22/2008 - 16:20

PX_FQDN should be the fully-qualified hostname of the server. If the server did not have a domain name when LMS was installed, then this value will be the same as PX_HOST. Setting PX_FQDN in this file alone is not sufficient. You would also need to adjust the same variable in the registry under HKLM\SOFTWARE\Cisco\Resource Manager\CurrentVersion\Environment. Using the changehostname.pl script is also a good solution provided md.properties is otherwise in tact.


This Discussion