CUCM 6 & Switchport config

Unanswered Question
Jan 22nd, 2008

I setup a test lab for our to be 6.(1a) machines. Setup went just fine.

I set the switchports up just like they are on our production servers with:

switchport access vlan 172

spanning-tree port fast

However, as soon as I enable the "switchport access vlan 172" I can't connect to the CUCM web admin. The phones register, but I can't access the admin.

If I remove the "switchport access vlan 172" the phone unregisters but I can access the web admin.

Besides the ports that the CUCM servers are in, the rest of the ports are set to "switchport voice vlan 172", "switchport mode trunk", and "switchport trunk encapsulation dot1q"

What am I doing wrong here? The ports are setup exactly the same as they are in our 4.x production domain.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dennisbehrens Tue, 01/22/2008 - 16:53

It sounds like you may have the CUCM servers on the wrong subnet. By setting the switchport to "switchport access vlan 172", you are setting the switchport to be on Vlan 172. When the servers are on the Voice VLAN, they should have an IP address on that network. It seems like you may have assigned the servers an address that belongs on your Data VLAN.

Is this possible?

What model of switches are you using? It appears that the configuration doesn't have any QoS. The trunk port configuration is less than ideal. Unless you have a 3500XL or something else that can't support newer features, I'd suggest you make some improvements in this area.

Dennis

snooter Wed, 01/23/2008 - 06:03

The switch is indeed a 3500XL

The CUCM servers have an ip of 172.16.x.x

This same setup with CCM 4.1.3 is working just fine on another 3500XL I've got setup in our production domain.

I'm at a loss..

snooter Wed, 01/23/2008 - 06:43

I've got the two totally separated. No way they could reach each other.

Here's a clip of the running config:

!

interface FastEthernet0/1

switchport access vlan 172

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 172

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 172

spanning-tree portfast

!

interface FastEthernet0/4

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 172

!

interface FastEthernet0/5

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 172

!

!

!

!

interface VLAN1

ip address 10.10.1.31 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

CUCM's servers are in f0/1 and 2, and there's a Unity box on f0/3

The laptop I'm using is plugged into the back of the 7940 phone that IS registered with the CUCM server. The laptop has an IP of 10.10.1.42.

dennisbehrens Wed, 01/23/2008 - 06:46

If they are on the same VLAN and the same IP subnet, they should be able to reach eachother.

ajaynstyagi Wed, 01/23/2008 - 07:39

Hi snooter,

As per my knowlage you must define two vlan,One for Data and one for Voice.

i am given an ex. for ip phone connected port.

interface FastEthernet0/4

switchport trunk encapsulation dot1q

switchport mode trunk

switchport access vlan 500

switchport mode access

switchport voice vlan 800

speed 100

duplex full

spanning-tree portfast

Let me know if still you have issue.

snooter Wed, 01/23/2008 - 09:23

I'd setup a second VLAN, but that isn't how my production domain is setup. I need to keep these exactly the same.

So, is there just something different about the 3500XL switch or what? I've duplicated everything from my production domain to the test lab. Everything is exactly the same except for the switch. My production domains switch is a 2960.

The switchport configurations are identical.

The only vlans I have are the default and 172 on both switches. CUCM ports are setup with access vlan 172, everything else is trunk and voice vlan 172.

On my production domain I can ping everything, on the test lab, anything that isn't set to access vlan 172 can't be reached.

I'm seriously confused here as this just isn't making sense.

snooter Wed, 01/23/2008 - 12:33

Finally figured this out.. it was the encapsulation on the switchport that connected to the router.

I should have noticed that.

Thanks for your help though.

Actions

This Discussion