Trunk And EtherChannel

Answered Question
Jan 22nd, 2008
User Badges:

Trunk and EtherChannel were united between Catalyst6509(CatOS) and

Catalyst2950.

EthetChannel was not able to be united ahead normally when turning on

power after it blacked out.

The composition and LOG are the following.

Are not there any hints?





---Physical connection---

CAT2950-FA0/23 <-> CAT6509-3/27

CAT2950-FA0/24 <-> CAT6509-4/27



---Config---

Cat6509 + Sup2

clear trunk 3/27 3-6,8-1001,1025-4094

set trunk 3/27 desirable dot1q 1-2,7,1002-1005

set port channel 3/27 mode desirable silent

clear trunk 4/27 3-6,8-1001,1025-4094

set trunk 4/27 desirable dot1q 1-2,7,1002-1005

set port channel 4/27 mode desirable silent


Cat2950

!

interface FastEthernet0/23

switchport trunk allowed vlan 1,2,7,1002-1005

switchport mode trunk

channel-group 1 mode desirable

!

interface FastEthernet0/24

switchport trunk allowed vlan 1,2,7,1002-1005

switchport mode trunk

channel-group 1 mode desirable

!



---LOG---

Cat2950

%EC-5-DONTBNDL: Fa0/24 suspended: incompatible partner port with FastEthernet0/23

%EC-5-DONTBNDL: Fa0/24 suspended: incompatible partner port with FastEthernet0/23


Cat6509

%DTP-5-NONTRUNKPORTON:Port 4/27 has become non-trunk

%DTP-5-TRUNKPORTON:Port 4/27 has become dot1q trunk

%DTP-5-NONTRUNKPORTON:Port 4/27 has become non-trunk

%DTP-5-TRUNKPORTON:Port 4/27 has become dot1q trunk



---PORT STATUS---

Cat6509

4/27 connected trunk a-full a-100 10/100BaseTX


Cat2950

Fa0/24 notconnect trunk a-full a-100 10/100BaseTX

Correct Answer by glen.grant about 9 years 2 months ago

I believe Edison is correct , on the catos side when you do the ports individually it will put them in different port channel groups and won't be able to agregate them which is indicated by your debug . Group them together and they should build the channel and trunk just fine . We haven't had any problems autonegotiating trunks or etherchannels on catos boxes.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (4 ratings)
Loading.
Edison Ortiz Tue, 01/22/2008 - 19:32
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

On the CatOS side type:


set port channel 3/27,4/27


On the 2950 side type:


interface range f0/23-24

shut

no shut



HTH,


__


Edison.

h.hatae Tue, 01/22/2008 - 20:08
User Badges:

thank you.


The setting has already been done.

Besides, though there might be a cause ・・・


set port channel 3/27,4/27 28

s.arunkumar Tue, 01/22/2008 - 19:37
User Badges:
  • Bronze, 100 points or more

Hi

I think u are missing with cmd for trunking method to be used at 2950.

Use the cmd "switchport trunk encapsulation dot1q" on ports fa0/23 and fa0/24..


Also i dont thing the Pgap need to configure on silent mode.Silent mode is used when the other end is not capable of Pgap.


arun


Edison Ortiz Tue, 01/22/2008 - 19:40
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Arun,


2950 does not support ISL hence the only option is 802.1q


When there is only one option, the encapsulation command is not available.


I believe the problem is with the CatOS not having 3/27 and 4/27 as channel partners. The command I recommended should fix the issue.


__


Edison.


s.arunkumar Tue, 01/22/2008 - 19:44
User Badges:
  • Bronze, 100 points or more

Thanks edison for correcting me... :)


arun

h.hatae Tue, 01/22/2008 - 20:27
User Badges:

I tried the below.

ï½¥The Trunk mode is changed from Dynamic to turning on and it connects it. (2950 was

connected with LAN cable between 6509 again. )

ï½¥Restart of 2950


Debug was made effective by 2950 and the information gathering was

done.

debug dtp event

debug pagp event

debug dtp packet


The result is appended LOG.


Is anything understood?

I am doubting that PAGP is doubtful.



Attachment: 
Edison Ortiz Tue, 01/22/2008 - 20:41
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

1) Can you change the trunk on the 6509 from desirable to on ?


2) Can you change the channel-group on the 2950 from desirable to auto ?


Do step 1 first, if it doesn't work then do step 2.


__


Edison.

h.hatae Wed, 01/23/2008 - 16:34
User Badges:

Thank you for advice.


I will try on weekend.

It reports on the result again.


Correct Answer
glen.grant Wed, 01/23/2008 - 17:04
User Badges:
  • Purple, 4500 points or more

I believe Edison is correct , on the catos side when you do the ports individually it will put them in different port channel groups and won't be able to agregate them which is indicated by your debug . Group them together and they should build the channel and trunk just fine . We haven't had any problems autonegotiating trunks or etherchannels on catos boxes.

h.hatae Mon, 01/28/2008 - 01:04
User Badges:

The setting change was done getting a hint from advice.

When the channel setting of 6509 and 2950 was made ON Mode, it became

normal.


Thank you.

Actions

This Discussion