Separate dial-peers for voice and fax

Unanswered Question
Jan 22nd, 2008

Hi Gurus

My setup is as follows:

customer----Leg1(SIP)------IPIPGW----------Leg2(SIP)--------Huawei softswitch X3000

For both leg1 and leg 2, I have configured a codec preference as follows:

voice class codec 1

codec preference 1 g729br8

codec preference 2 g729r8

For voice, this works ok and g729br8 is negotiated both sides. This doesn't work for FAX since FAX (from ATA 186) needs g711 for FAX passthrough.

To make fax work, I change codec class as follows

voice class codec 1

codec preference 1 g729br8

codec preference 2 g729r8

codec preference 3 g711alaw

with this FAX works ok. However voice codecs are negotiated as follows:

Leg 1 g729br8 and Leg 2 g711alaw. This leads to one way audio since a transcoder is not configured. IT also means that as long as I allow g711, the softswitch is preffering it regardless of codec preference on the IPIPGW.

My problem is as follows:

Transcoding is not an option for me since the 2801 router i have can't handle like 60 simultaneous transcoding sessions plus i need a H323 to SIP for transcoding to happen (SIP-SIP doesn't support to the best of my research). I have hustled with service provider to change codec preference on the softswitch but haven't succeeded. Does someone know how to change the codecs on huawei x3000 softswitch?

Is it possible to have a separate dial-peer for voice and a separate one for fax? this would solve my problems. My current dial-peers as follows?

dial-peer voice 1 voip

description incoming dial-plan (from softswitch)

translation-profile outgoing to service provider

destination-pattern .T

modem passthrough nse codec g711alaw

voice-class codec 1

session protocol sipv2

session target ipv4:196.0.69.4

incoming called-number 041744....

dtmf-relay rtp-nte

fax rate disable

!

dial-peer voice 2 voip

description outgoing dialplan (to CCMs)

destination-pattern 041744....

modem passthrough nse codec g711alaw

voice-class codec 1

session protocol sipv2

session target ipv4:196.0.70.19

incoming called-number .T

dtmf-relay rtp-nte

fax rate disable

help will be appreciated. rating a must.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sdekooter Mon, 01/28/2008 - 12:53

Hi there, two things:

1) why use the current dialpeer config? Do they work? (is your CME dialplan 041744....) or is your 'softswitch'?) Because I do not understand destination-pattern and incoming called-number

2) depending on 1, if you have a succesfull incomin dialpeer, why not simple create another one with a more specific pattern?

KR, Steve

solomonthuo Thu, 02/07/2008 - 23:47

hi steve

the dial-peers have been working ok for calls but i will re-think about the flow. The 041744.... are the internal numbers on the CCMS. will get back to you once i check the possibility of adding a specific dial -peer for fax.

regards

Actions

This Discussion