Wireless bridge as a trunk

Unanswered Question
Jan 24th, 2008
User Badges:

Hi,


I have a switch network running VLANs, and I need to extend this into a building that I can't physically get a cable to. I have two 1300 series bridges that I want to use to create a bridge between two switches in either building.


I need multiple VLANs to pass over the bridge.


Looking at the documentation the only examples I can find involve creating subinterfaces on the bridge ethernet port and setting each subinterface to its own VLAN and SSID.


Is there a way to get the devices to act as a bridge carrying multiple VLANs over a single SSID?


I don't want the bridges to act as Access Points - only bridges.


Cheers,

Ben

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (3 ratings)
Loading.
youmansk235 Thu, 01/24/2008 - 09:24
User Badges:

The 1410 bridge will do it. We are doing it right now. You have to setup sub interfaces on the radio but they do not need multiple ssid's. Try setting up one ssid on the 1300. Then under the radio and ethernet interfaces setup your sub interfaces. Under the radio interface setup your vlan encryption. The 1410 installation document has more details. I would assume that the 1300 will work the same.

abrahamj Thu, 02/07/2008 - 14:45
User Badges:

The wireless bridge is logically made up of two components: a transceiver and a bridge. The transceiver is a radio that will forward traffic to the next bridge; it doesn't care about VLANS. The management interface of the bridge should be on a separate IP addressing scheme, a /29 VLAN say, that looks like a P2P connection to the L3 gear it touches. If you are going L3 to L2 switch, keep the bridges on the vlan supporting the management interface of the switch--the vlans defined on the L3 gear will come through intact.

misd.network.support Thu, 02/07/2008 - 23:06
User Badges:

Abrahami,


The management interface BVI when dealing with sub-interfaces has to be on the native VLAN. I have made the management VLAN of the L2 switches the native VLAN and given the bridges an IP on that VLAN. Is this secure?


Secondly, I don't understand how to configure the FastEthernet port on the bridge to connect to the L2 switch. The switch must be a trunk in order to support multiple VLANs.


I can't find a way to configure the fastethernet on the bridge as a trunk without using multiple sub interfaces - so I don't understand the relationship between the radio and fastethernet sub interfaces.


Should i not be defining sub interfaces on the radio? Do I just map all fastethernet sub interfaces to a single SSID?

timkaye@empired Mon, 02/11/2008 - 18:54
User Badges:

Hi,


Below is a sample (working config) taken from a 1200 series.


!

dot11 ssid my-ssid

vlan 1

authentication open

infrastructure-ssid

!

power inline negotiation injector 001d.e692.b808

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

load-interval 30

shutdown

!

encryption key 1 size 128bit 7 F31439656A9323F25A0AB8F0B728 transmit-key

encryption mode wep mandatory

!

ssid my-ssid

!

parent 1 001d.7126.7680

station-role non-root bridge

mobile station scan 2462

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption key 1 size 128bit 7 F31439656A9323F25A0AB8F0B728 transmit-key

encryption mode wep mandatory

!

ssid my-ssid

!

antenna transmit right

antenna receive right

parent 1 001d.7126.7680

speed basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 36.0 48.0 54.0

station-role non-root bridge

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no ip route-cache

no snmp trap link-status

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1.145

encapsulation dot1Q 145

no ip route-cache

no snmp trap link-status

bridge-group 145

bridge-group 145 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

speed 100

full-duplex

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

no snmp trap link-status

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet0.145

encapsulation dot1Q 145

no ip route-cache

no snmp trap link-status

bridge-group 145

bridge-group 145 spanning-disabled

!

interface BVI1

ip address 10.30.55.35 255.255.248.0

no ip route-cache

!

ip default-gateway 10.30.55



Hopefully this helps.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode